From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S966291AbcHBNOq (ORCPT ); Tue, 2 Aug 2016 09:14:46 -0400 Received: from mga03.intel.com ([134.134.136.65]:9721 "EHLO mga03.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S966256AbcHBNNx (ORCPT ); Tue, 2 Aug 2016 09:13:53 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="149331131" From: Baole Ni To: perex@perex.cz, tiwai@suse.com, serge@hallyn.com, davem@davemloft.net, kadlec@blackhole.kfki.hu, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: alsa-devel@alsa-project.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, aryabinin@virtuozzo.com Subject: [PATCH 1154/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 20:21:15 +0800 Message-Id: <20160802122115.27064-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- sound/core/seq/seq_dummy.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/sound/core/seq/seq_dummy.c b/sound/core/seq/seq_dummy.c index d3a2ec4..1b01fb6 100644 --- a/sound/core/seq/seq_dummy.c +++ b/sound/core/seq/seq_dummy.c @@ -67,9 +67,9 @@ MODULE_ALIAS("snd-seq-client-" __stringify(SNDRV_SEQ_CLIENT_DUMMY)); static int ports = 1; static bool duplex; -module_param(ports, int, 0444); +module_param(ports, int, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(ports, "number of ports to be created"); -module_param(duplex, bool, 0444); +module_param(duplex, bool, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(duplex, "create DUPLEX ports"); struct snd_seq_dummy_port { -- 2.9.2