From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S966391AbcHBNLc (ORCPT ); Tue, 2 Aug 2016 09:11:32 -0400 Received: from mga03.intel.com ([134.134.136.65]:21208 "EHLO mga03.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S966300AbcHBNKR (ORCPT ); Tue, 2 Aug 2016 09:10:17 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1028299445" From: Baole Ni To: perex@perex.cz, tiwai@suse.com, swarren@wwwdotorg.org, thierry.reding@gmail.com, gnurou@gmail.com, kadlec@blackhole.kfki.hu, davem@davemloft.net, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: alsa-devel@alsa-project.org, linux-kernel@vger.kernel.org, libin.yang@linux.intel.com, vinod.koul@intel.com, subhransu.s.prusty@intel.com, chuansheng.liu@intel.com, baolex.ni@intel.com, aryabinin@virtuozzo.com Subject: [PATCH 1233/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 20:29:25 +0800 Message-Id: <20160802122925.32491-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- sound/pci/hda/patch_hdmi.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/sound/pci/hda/patch_hdmi.c b/sound/pci/hda/patch_hdmi.c index d0d5ad8..6107c13 100644 --- a/sound/pci/hda/patch_hdmi.c +++ b/sound/pci/hda/patch_hdmi.c @@ -45,7 +45,7 @@ #include "hda_jack.h" static bool static_hdmi_pcm; -module_param(static_hdmi_pcm, bool, 0644); +module_param(static_hdmi_pcm, bool, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(static_hdmi_pcm, "Don't restrict PCM parameters per ELD info"); #define is_haswell(codec) ((codec)->core.vendor_id == 0x80862807) -- 2.9.2