From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S966526AbcHBNZg (ORCPT ); Tue, 2 Aug 2016 09:25:36 -0400 Received: from mga14.intel.com ([192.55.52.115]:58864 "EHLO mga14.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S966132AbcHBNJw (ORCPT ); Tue, 2 Aug 2016 09:09:52 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="149338462" From: Baole Ni To: perex@perex.cz, tiwai@suse.com, thierry.reding@gmail.com, gnurou@gmail.com, kadlec@blackhole.kfki.hu, davem@davemloft.net, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: alsa-devel@alsa-project.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, aryabinin@virtuozzo.com Subject: [PATCH 1258/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 20:32:10 +0800 Message-Id: <20160802123210.1821-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- sound/pci/via82xx_modem.c | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/sound/pci/via82xx_modem.c b/sound/pci/via82xx_modem.c index 99b9137..98cd658 100644 --- a/sound/pci/via82xx_modem.c +++ b/sound/pci/via82xx_modem.c @@ -58,16 +58,16 @@ static int index = -2; /* Exclude the first card */ static char *id = SNDRV_DEFAULT_STR1; /* ID for this card */ static int ac97_clock = 48000; -module_param(index, int, 0444); +module_param(index, int, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(index, "Index value for VIA 82xx bridge."); -module_param(id, charp, 0444); +module_param(id, charp, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(id, "ID string for VIA 82xx bridge."); -module_param(ac97_clock, int, 0444); +module_param(ac97_clock, int, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(ac97_clock, "AC'97 codec clock (default 48000Hz)."); /* just for backward compatibility */ static bool enable; -module_param(enable, bool, 0444); +module_param(enable, bool, S_IRUSR | S_IRGRP | S_IROTH); /* -- 2.9.2