From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S967235AbcHBOEk (ORCPT ); Tue, 2 Aug 2016 10:04:40 -0400 Received: from mga09.intel.com ([134.134.136.24]:35427 "EHLO mga09.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S965772AbcHBOEU (ORCPT ); Tue, 2 Aug 2016 10:04:20 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1028302284" From: Baole Ni To: perex@perex.cz, tiwai@suse.com, davem@davemloft.net, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: alsa-devel@alsa-project.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, fabio.estevam@nxp.com, linus.walleij@linaro.org, zidan.wang@freescale.com, sachinpandhare@gmail.com, lars@metafoo.de Subject: [PATCH 1274/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 20:33:42 +0800 Message-Id: <20160802123342.2983-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- sound/sound_core.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/sound/sound_core.c b/sound/sound_core.c index 99b73c6..2c3c09c 100644 --- a/sound/sound_core.c +++ b/sound/sound_core.c @@ -154,7 +154,7 @@ static int preclaim_oss = 1; static int preclaim_oss = 0; #endif -module_param(preclaim_oss, int, 0444); +module_param(preclaim_oss, int, S_IRUSR | S_IRGRP | S_IROTH); static int soundcore_open(struct inode *, struct file *); -- 2.9.2