From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1422738AbcHEPCH (ORCPT ); Fri, 5 Aug 2016 11:02:07 -0400 Received: from foss.arm.com ([217.140.101.70]:56938 "EHLO foss.arm.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1422678AbcHEPCE (ORCPT ); Fri, 5 Aug 2016 11:02:04 -0400 Date: Fri, 5 Aug 2016 16:02:18 +0100 From: Juri Lelli To: Steven Rostedt Cc: peterz@infradead.org, linux-kernel@vger.kernel.org, mingo@redhat.com, luca.abeni@unitn.it, xpang@redhat.com Subject: Re: [PATCH v5] sched/deadline: remove useless param from setup_new_dl_entity Message-ID: <20160805150218.GI28125@e106622-lin> References: <1470391799-22939-1-git-send-email-juri.lelli@arm.com> <20160805095643.130194cf@gandalf.local.home> <20160805143444.GH28125@e106622-lin> <20160805105408.3780d599@gandalf.local.home> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20160805105408.3780d599@gandalf.local.home> User-Agent: Mutt/1.5.21 (2010-09-15) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 05/08/16 10:54, Steven Rostedt wrote: > On Fri, 5 Aug 2016 15:34:44 +0100 > Juri Lelli wrote: > > > On 05/08/16 09:56, Steven Rostedt wrote: > > > On Fri, 5 Aug 2016 11:09:59 +0100 > > > Juri Lelli wrote: > > > > > > > @@ -1720,19 +1720,28 @@ static void switched_from_dl(struct rq *rq, struct task_struct *p) > > > > */ > > > > static void switched_to_dl(struct rq *rq, struct task_struct *p) > > > > { > > > > - if (dl_time_before(p->dl.deadline, rq_clock(rq))) > > > > - setup_new_dl_entity(&p->dl, &p->dl); > > > > > > > > - if (task_on_rq_queued(p) && rq->curr != p) { > > > > + if (task_on_rq_queued(p)) { > > > > > > I always hated functions totally encapsulated by an if statement. This > > > can be a bit simpler (and less indented) if you have: > > > > > > /* If p is not queued, its parameters will be updated at wakeup */ > > > if (!task_on_rq_queued(p)) > > > return; > > > > > > [...] > > > > > > > You mean like what follows? > > > > I'll post a v6 if OK. > > > > Yes! I think that looks much nicer, and easier to read. > Yep. Way better. :) > You can add my Reviewed-by tag too. > Thanks! Best, - Juri