From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753129AbcHOPan (ORCPT ); Mon, 15 Aug 2016 11:30:43 -0400 Received: from mx1.redhat.com ([209.132.183.28]:52728 "EHLO mx1.redhat.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752812AbcHOPam (ORCPT ); Mon, 15 Aug 2016 11:30:42 -0400 Date: Mon, 15 Aug 2016 10:30:38 -0500 From: Josh Poimboeuf To: Andy Lutomirski Cc: Thomas Gleixner , Ingo Molnar , "H . Peter Anvin" , X86 ML , "linux-kernel@vger.kernel.org" , Linus Torvalds , Steven Rostedt , Brian Gerst , Kees Cook , Peter Zijlstra , Frederic Weisbecker , Byungchul Park , Nilay Vaish Subject: Re: [PATCH v3 19/51] x86/entry/32: rename 'error_code' to 'common_exception' Message-ID: <20160815153038.xll35k4f6uu7idp4@treble> References: <903a1ae21aba28790fdd73d2322ab31268511b3b.1471011425.git.jpoimboe@redhat.com> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline In-Reply-To: User-Agent: Mutt/1.6.0.1 (2016-04-01) X-Greylist: Sender IP whitelisted, not delayed by milter-greylist-4.5.16 (mx1.redhat.com [10.5.110.38]); Mon, 15 Aug 2016 15:30:41 +0000 (UTC) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Sun, Aug 14, 2016 at 12:40:03AM -0700, Andy Lutomirski wrote: > On Fri, Aug 12, 2016 at 7:28 AM, Josh Poimboeuf wrote: > > The 'error_code' label is awkwardly named, especially when it shows up > > in a stack trace. Move it to its own local function and rename it to > > 'common_exception', analagous to the existing 'common_interrupt'. > > > > This also makes related stack traces more sensible. > > This is okay with me. You could also call it "error_entry" for > consistency with x86_64. On x86_64, error_entry is just a helper function which doesn't call the C handler, and so it doesn't usually show up in the stack trace. So its scope is quite different from error_code/common_exception. -- Josh