From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1760247AbcISHvJ (ORCPT ); Mon, 19 Sep 2016 03:51:09 -0400 Received: from mail.linuxfoundation.org ([140.211.169.12]:33221 "EHLO mail.linuxfoundation.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1757003AbcISHvI (ORCPT ); Mon, 19 Sep 2016 03:51:08 -0400 Date: Mon, 19 Sep 2016 09:51:13 +0200 From: Greg Kroah-Hartman To: James Simmons Cc: devel@driverdev.osuosl.org, Andreas Dilger , Oleg Drokin , Lai Siyao , Linux Kernel Mailing List , Lustre Development List Subject: Re: [PATCH 070/124] staging: lustre: statahead: small fixes and cleanup Message-ID: <20160919075113.GA11295@kroah.com> References: <1474231143-4061-1-git-send-email-jsimmons@infradead.org> <1474231143-4061-71-git-send-email-jsimmons@infradead.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1474231143-4061-71-git-send-email-jsimmons@infradead.org> User-Agent: Mutt/1.7.0 (2016-08-17) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Sun, Sep 18, 2016 at 04:38:09PM -0400, James Simmons wrote: > From: Lai Siyao > > small fixes: > * when 'unplug' is set for ll_statahead(), sa_put() shouldn't kill > the entry found, because its inflight RPC may not finish yet. > * remove 'sai_generation', add 'lli_sa_generation' because the > former one is not safe to access without lock. > * revalidate_statahead_dentry() may fail to wait for statahead > entry to become ready, in this case it should not release this > entry, because it may be used by inflight statahead RPC. > > cleanups: > * rename ll_statahead_enter() to ll_statahead(). > * move dentry 'lld_sa_generation' update to ll_statahead() to > simplify code and logic. > * other small cleanups. That's a lot of different things to be doing all at once in a single patch. I know this came from your tree, but in the future, please push back and ask for broken up patches, as that is required for "upstream" here. I'll take this for now :( greg k-h