From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755278AbcIZXcu (ORCPT ); Mon, 26 Sep 2016 19:32:50 -0400 Received: from mail.linuxfoundation.org ([140.211.169.12]:47290 "EHLO mail.linuxfoundation.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S933275AbcIZXcj (ORCPT ); Mon, 26 Sep 2016 19:32:39 -0400 Date: Mon, 26 Sep 2016 16:32:26 -0700 From: Andrew Morton To: Andrey Konovalov Cc: Dmitry Vyukov , Nicolai Stange , Andrey Ryabinin , Kees Cook , James Morse , linux-kernel@vger.kernel.org, vegard.nossum@oracle.com, quentin.casasnovas@oracle.com, ryabinin.a.a@gmail.com, Thomas Gleixner , Ingo Molnar , Peter Zijlstra Subject: Re: [PATCH] kcov: properly check if we are in an interrupt Message-Id: <20160926163226.35cc76eb1a06083440cbb86d@linux-foundation.org> In-Reply-To: <1474642273-112248-1-git-send-email-andreyknvl@google.com> References: <1474642273-112248-1-git-send-email-andreyknvl@google.com> X-Mailer: Sylpheed 3.4.1 (GTK+ 2.24.23; x86_64-pc-linux-gnu) Mime-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, 23 Sep 2016 16:51:13 +0200 Andrey Konovalov wrote: > in_interrupt() returns a nonzero value when we are either in an > interrupt or have bh disabled via local_bh_disable(). Since we are > interested in only ignoring coverage from actual interrupts, do a > proper check of whether we are really in an interrupt. > > Signed-off-by: Andrey Konovalov > --- > It would look totally better to reuse in_irq(), in_serving_softirq() and > in_nmi() instead of checking flags manually, but that leads to slower > generated code (three separate tests for each of the flags). Would it be > better to add another macro to preempt.h that would check if we're actually > in interrupt and use it? Yes please. Is there anywhere else where such a macro can be used? > --- a/kernel/kcov.c > +++ b/kernel/kcov.c > @@ -54,7 +54,8 @@ void notrace __sanitizer_cov_trace_pc(void) > * We are interested in code coverage as a function of a syscall inputs, > * so we ignore code executed in interrupts. > */ > - if (!t || in_interrupt()) > + if (!t || (preempt_count() & (HARDIRQ_MASK | SOFTIRQ_OFFSET > + | NMI_MASK))) Or include a prominent and very apologetic comment here explaining why it is open-coded. But I do agree that not open-coding it is better.