mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Jean-Francois Moine <moinejf@free.fr>
To: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>
Cc: Rob Herring <robh+dt@kernel.org>, Mark Brown <broonie@kernel.org>,
	Linux-DT <devicetree@vger.kernel.org>,
	Linux-ALSA <alsa-devel@alsa-project.org>,
	Liam Girdwood <lgirdwood@gmail.com>,
	Linux-Kernel <linux-kernel@vger.kernel.org>,
	Simon <horms@verge.net.au>,
	Laurent <laurent.pinchart@ideasonboard.com>,
	Grant Likely <grant.likely@linaro.org>,
	Frank Rowand <frowand.list@gmail.com>,
	Guennadi <g.liakhovetski@gmx.de>
Subject: Re: [alsa-devel] [PATCH 08/23] ASoC: soc-core: snd_soc_get_dai_name() become non static
Date: Tue, 18 Oct 2016 09:27:15 +0200	[thread overview]
Message-ID: <20161018092715.16e0943b481f9bc6885eb4f4@free.fr> (raw)
In-Reply-To: <87h98b4c30.wl%kuninori.morimoto.gx@renesas.com>

On Mon, 17 Oct 2016 08:34:19 +0000
Kuninori Morimoto <kuninori.morimoto.gx@renesas.com> wrote:

> From: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>
> 
> snd_soc_get_dai_name() is used from snd_soc_of_get_dai_name(),
> and it is assuming that DT is using "sound-dai" / "#sound-dai-cells".
> But graph base DT is using "remote-endpoint". This patch makes
> snd_soc_get_dai_name() non static for graph support.
> 
> Signed-off-by: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>
> ---
>  include/sound/soc.h  | 2 ++
>  sound/soc/soc-core.c | 3 ++-
>  2 files changed, 4 insertions(+), 1 deletion(-)
> 
> diff --git a/include/sound/soc.h b/include/sound/soc.h
> index fd63d23..77b01c4 100644
> --- a/include/sound/soc.h
> +++ b/include/sound/soc.h
> @@ -1677,6 +1677,8 @@ unsigned int snd_soc_of_parse_daifmt(struct device_node *np,
>  				     const char *prefix,
>  				     struct device_node **bitclkmaster,
>  				     struct device_node **framemaster);
> +int snd_soc_get_dai_name(struct of_phandle_args *args,
> +			 const char **dai_name);
>  int snd_soc_of_get_dai_name(struct device_node *of_node,
>  			    const char **dai_name);
>  int snd_soc_of_get_dai_link_codecs(struct device *dev,
> diff --git a/sound/soc/soc-core.c b/sound/soc/soc-core.c
> index 8371488..6f911f4 100644
> --- a/sound/soc/soc-core.c
> +++ b/sound/soc/soc-core.c
> @@ -3794,7 +3794,7 @@ unsigned int snd_soc_of_parse_daifmt(struct device_node *np,
>  }
>  EXPORT_SYMBOL_GPL(snd_soc_of_parse_daifmt);
>  
> -static int snd_soc_get_dai_name(struct of_phandle_args *args,
> +int snd_soc_get_dai_name(struct of_phandle_args *args,
>  				const char **dai_name)
>  {
>  	struct snd_soc_component *pos;
> @@ -3846,6 +3846,7 @@ static int snd_soc_get_dai_name(struct of_phandle_args *args,
>  	mutex_unlock(&client_mutex);
>  	return ret;
>  }
> +EXPORT_SYMBOL_GPL(snd_soc_get_dai_name);
>  
>  int snd_soc_of_get_dai_name(struct device_node *of_node,
>  			    const char **dai_name)
> -- 
> 1.9.1

I already proposed this patch
 http://mailman.alsa-project.org/pipermail/alsa-devel/2015-January/086870.html
but it seems people were not interested.
I hope now is the right time.

Acked-by: Jean-Francois Moine <moinejf@free.fr>

-- 
Ken ar c'hentañ	|	      ** Breizh ha Linux atav! **
Jef		|		http://moinejf.free.fr/

  reply	other threads:[~2016-10-18  7:27 UTC|newest]

Thread overview: 41+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-10-17  8:30 [PATCH 0/23] ASoC: add OF graph base simple-card Kuninori Morimoto
2016-10-17  8:32 ` [PATCH 01/23] ASoC: simple-scu-card: code sync: follow to simple family style Kuninori Morimoto
2016-10-28 18:49   ` Applied "ASoC: simple-scu-card: code sync: follow to simple family style" to the asoc tree Mark Brown
2016-10-17  8:32 ` [PATCH 02/23] ASoC: simple-scu-card: code sync: rename asoc_simple_card_priv Kuninori Morimoto
2016-10-28 18:48   ` Applied "ASoC: simple-scu-card: code sync: rename asoc_simple_card_priv" to the asoc tree Mark Brown
2016-10-17  8:32 ` [PATCH 03/23] ASoC: simple-scu-card: code sync: tidyup props/link naming Kuninori Morimoto
2016-10-28 18:48   ` Applied "ASoC: simple-scu-card: code sync: tidyup props/link naming" to the asoc tree Mark Brown
2016-10-17  8:33 ` [PATCH 04/23] ASoC: soc-core: adjust for graph on snd_soc_of_parse_card_name Kuninori Morimoto
2016-11-11 15:28   ` Applied "ASoC: soc-core: adjust for graph on snd_soc_of_parse_card_name" to the asoc tree Mark Brown
2016-10-17  8:33 ` [PATCH 05/23] ASoC: soc-core: adjust for graph on snd_soc_of_parse_audio_simple_widgets Kuninori Morimoto
2016-11-11 15:28   ` Applied "ASoC: soc-core: adjust for graph on snd_soc_of_parse_audio_simple_widgets" to the asoc tree Mark Brown
2016-10-17  8:33 ` [PATCH 06/23] ASoC: soc-core: adjust for graph on snd_soc_of_parse_audio_routing Kuninori Morimoto
2016-11-11 15:29   ` Applied "ASoC: soc-core: adjust for graph on snd_soc_of_parse_audio_routing" to the asoc tree Mark Brown
2016-10-17  8:34 ` [PATCH 07/23] ASoC: soc-core: adjust for graph on snd_soc_of_parse_audio_prefix Kuninori Morimoto
2016-11-11 15:28   ` Applied "ASoC: soc-core: adjust for graph on snd_soc_of_parse_audio_prefix" to the asoc tree Mark Brown
2016-10-17  8:34 ` [PATCH 08/23] ASoC: soc-core: snd_soc_get_dai_name() become non static Kuninori Morimoto
2016-10-18  7:27   ` Jean-Francois Moine [this message]
2016-11-11 15:28   ` Applied "ASoC: soc-core: snd_soc_get_dai_name() become non static" to the asoc tree Mark Brown
2016-10-17  8:34 ` [PATCH 09/23] ASoC: simple-card-utils: remove unnecessary cpu/codec pointer check Kuninori Morimoto
2016-10-28 18:48   ` Applied "ASoC: simple-card-utils: remove unnecessary cpu/codec pointer check" to the asoc tree Mark Brown
2016-10-17  8:34 ` [PATCH 10/23] ASoC: simple-card-utils: adjust for graph on asoc_simple_card_parse_card_name Kuninori Morimoto
2016-10-17  8:35 ` [PATCH 11/23] Documentation: of: add type property Kuninori Morimoto
2016-10-17  8:35 ` [PATCH 12/23] of_graph: add of_graph_get_remote_endpoint() Kuninori Morimoto
2016-10-17  8:36 ` [PATCH 13/23] of_graph: add of_graph_port_type_is() Kuninori Morimoto
2016-10-17  8:36 ` [PATCH 14/23] of_graph: add of_graph_get_port_parent() Kuninori Morimoto
2016-10-17  8:36 ` [PATCH 15/23] of_graph: add of_graph_get_top_port() Kuninori Morimoto
2016-10-17  8:37 ` [PATCH 16/23] of_graph: add for_each_of_port() / for_each_of_endpoint_in_port() Kuninori Morimoto
2016-10-17  8:37 ` [PATCH 17/23] of_graph: add of_graph_get_endpoint_count() Kuninori Morimoto
2016-10-17  8:37 ` [PATCH 18/23] ASoC: simple-card-utils: add asoc_simple_card_parse_graph_dai() Kuninori Morimoto
2016-10-17  8:38 ` [PATCH 19/23] ASoC: simple-card-utils: add asoc_simple_card_try_to_probe_graph_card() Kuninori Morimoto
2016-10-17  8:38 ` [PATCH 20/23] ASoC: add simple-graph-card document Kuninori Morimoto
2016-10-18 15:53   ` Rob Herring
2016-10-19  1:36     ` Kuninori Morimoto
2016-10-19  2:39       ` Rob Herring
2016-10-19  6:13         ` Kuninori Morimoto
2016-10-21  5:45       ` Kuninori Morimoto
2016-10-17  8:38 ` [PATCH 21/23] ASoC: add simple-graph-card support Kuninori Morimoto
2016-10-17  8:39 ` [PATCH 22/23] ASoC: add simple-graph-scu-card document Kuninori Morimoto
2016-10-17  8:39 ` [PATCH 23/23] ASoC: add simple-graph-scu-card support Kuninori Morimoto
2016-10-18  7:10 ` [alsa-devel] [PATCH 0/23] ASoC: add OF graph base simple-card Jean-Francois Moine
2016-10-18  8:44   ` Kuninori Morimoto

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20161018092715.16e0943b481f9bc6885eb4f4@free.fr \
    --to=moinejf@free.fr \
    --cc=alsa-devel@alsa-project.org \
    --cc=broonie@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=frowand.list@gmail.com \
    --cc=g.liakhovetski@gmx.de \
    --cc=grant.likely@linaro.org \
    --cc=horms@verge.net.au \
    --cc=kuninori.morimoto.gx@renesas.com \
    --cc=laurent.pinchart@ideasonboard.com \
    --cc=lgirdwood@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=robh+dt@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®