From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S934153AbcKJPW5 (ORCPT ); Thu, 10 Nov 2016 10:22:57 -0500 Received: from 8bytes.org ([81.169.241.247]:60262 "EHLO theia.8bytes.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S933838AbcKJPWn (ORCPT ); Thu, 10 Nov 2016 10:22:43 -0500 Date: Thu, 10 Nov 2016 16:22:41 +0100 From: Joerg Roedel To: Eric Auger Cc: eric.auger.pro@gmail.com, christoffer.dall@linaro.org, marc.zyngier@arm.com, robin.murphy@arm.com, alex.williamson@redhat.com, will.deacon@arm.com, tglx@linutronix.de, jason@lakedaemon.net, linux-arm-kernel@lists.infradead.org, kvm@vger.kernel.org, drjones@redhat.com, linux-kernel@vger.kernel.org, pranav.sawargaonkar@gmail.com, iommu@lists.linux-foundation.org, punit.agrawal@arm.com, diana.craciun@nxp.com Subject: Re: [RFC v2 2/8] iommu/iova: fix __alloc_and_insert_iova_range Message-ID: <20161110152241.GF2078@8bytes.org> References: <1478258646-3117-1-git-send-email-eric.auger@redhat.com> <1478258646-3117-3-git-send-email-eric.auger@redhat.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1478258646-3117-3-git-send-email-eric.auger@redhat.com> User-Agent: Mutt/1.5.21 (2010-09-15) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, Nov 04, 2016 at 11:24:00AM +0000, Eric Auger wrote: > Fix the size check within start_pfn and limit_pfn. > > Signed-off-by: Eric Auger > > --- > > the issue was observed when playing with 1 page iova domain with > higher iova reserved. > --- > drivers/iommu/iova.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/iommu/iova.c b/drivers/iommu/iova.c > index e23001b..ee29dbf 100644 > --- a/drivers/iommu/iova.c > +++ b/drivers/iommu/iova.c > @@ -147,7 +147,7 @@ static int __alloc_and_insert_iova_range(struct iova_domain *iovad, > if (!curr) { > if (size_aligned) > pad_size = iova_get_pad_size(size, limit_pfn); > - if ((iovad->start_pfn + size + pad_size) > limit_pfn) { > + if ((iovad->start_pfn + size + pad_size - 1) > limit_pfn) { A >= check is more readable here. Joerg