From: Milo Kim <woogyom.kim@gmail.com>
To: Sebastian Reichel <sre@kernel.org>
Cc: Enric Balletbo i Serra <enric.balletbo@collabora.com>,
linux-pm@vger.kernel.org, linux-kernel@vger.kernel.org,
Milo Kim <woogyom.kim@gmail.com>
Subject: [PATCH v2 0/8] power: supply: tps65217: Support USB charger feature
Date: Fri, 9 Dec 2016 16:48:58 +0900 [thread overview]
Message-ID: <20161209074906.27545-1-woogyom.kim@gmail.com> (raw)
TPS65217 device supports two charger inputs - AC and USB.
Currently, only AC charger is supported. This patch-set adds USB charger
feature. Tested on Beaglebone black.
Patch 1: Main patch
Patch 2, 3: Clean up for charger driver data
Patch 4 ~ 8: Naming changes for generic power supply class structure
v2:
Regenerate the patchset for better code review
Milo Kim (8):
power: supply: tps65217: Support USB charger interrupt
power: supply: tps65217: Use 'poll_task' on unloading the module
power: supply: tps65217: Remove IRQ data from driver data
power: supply: tps65217: Use generic name for charger online
power: supply: tps65217: Use generic name for power supply structure
power: supply: tps65217: Use generic name for power supply property
power: supply: tps65217: Use generic name for get_property()
power: supply: tps65217: Use generic charger name
drivers/power/supply/tps65217_charger.c | 99 ++++++++++++++++++---------------
1 file changed, 53 insertions(+), 46 deletions(-)
--
2.9.3
next reply other threads:[~2016-12-09 7:49 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-12-09 7:48 Milo Kim [this message]
2016-12-09 7:48 ` [PATCH v2 1/8] power: supply: tps65217: Support USB charger interrupt Milo Kim
2016-12-09 7:49 ` [PATCH v2 2/8] power: supply: tps65217: Use 'poll_task' on unloading the module Milo Kim
2016-12-09 7:49 ` [PATCH v2 3/8] power: supply: tps65217: Remove IRQ data from driver data Milo Kim
2016-12-09 7:49 ` [PATCH v2 4/8] power: supply: tps65217: Use generic name for charger online Milo Kim
2016-12-09 7:49 ` [PATCH v2 5/8] power: supply: tps65217: Use generic name for power supply structure Milo Kim
2016-12-09 7:49 ` [PATCH v2 6/8] power: supply: tps65217: Use generic name for power supply property Milo Kim
2016-12-09 7:49 ` [PATCH v2 7/8] power: supply: tps65217: Use generic name for get_property() Milo Kim
2016-12-09 7:49 ` [PATCH v2 8/8] power: supply: tps65217: Use generic charger name Milo Kim
2016-12-17 16:24 ` [PATCH v2 0/8] power: supply: tps65217: Support USB charger feature Sebastian Reichel
2016-12-18 2:57 ` Milo Kim
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20161209074906.27545-1-woogyom.kim@gmail.com \
--to=woogyom.kim@gmail.com \
--cc=enric.balletbo@collabora.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=sre@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome