From: Petr Mladek <pmladek@suse.com>
To: Geert Uytterhoeven <geert@linux-m68k.org>
Cc: Linus Torvalds <torvalds@linux-foundation.org>,
Joe Perches <joe@perches.com>,
Andrew Morton <akpm@linux-foundation.org>,
Sergey Senozhatsky <sergey.senozhatsky.work@gmail.com>,
Steven Rostedt <rostedt@goodmis.org>,
Jason Wessel <jason.wessel@windriver.com>,
Jaroslav Kysela <perex@perex.cz>, Takashi Iwai <tiwai@suse.com>,
Chris Mason <clm@fb.com>, Josef Bacik <jbacik@fb.com>,
David Sterba <dsterba@suse.com>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v2 3/4] printk/btrfs: Handle more message headers
Date: Tue, 13 Dec 2016 14:52:47 +0100 [thread overview]
Message-ID: <20161213135246.GQ3506@pathway.suse.cz> (raw)
In-Reply-To: <CAMuHMdUer4VkNmAgp7kLX1KukVFKYzNvi69EKuY-CuAqh9u-ww@mail.gmail.com>
On Tue 2016-12-13 10:21:27, Geert Uytterhoeven wrote:
> Hi Petr,
>
> On Wed, Nov 9, 2016 at 1:41 PM, Petr Mladek <pmladek@suse.com> wrote:
> > The commit 4bcc595ccd80decb4245096e ("printk: reinstate KERN_CONT for
> > printing continuation lines") allows to define more message headers
> > for a single message. The motivation is that continuous lines might
> > get mixed. Therefore it make sense to define the right log level
> > for every piece of a cont line.
> >
> > The current btrfs_printk() macros do not support continuous lines
> > at the moment. But better be prepared for a custom messages and
> > avoid potential "lvl" buffer overflow.
> >
> > This patch iterates over the entire message header. It is interested
> > only into the message level like the original code.
> >
> > This patch also introduces PRINTK_MAX_SINGLE_HEADER_LEN. Three bytes
> > are enough for the message level header at the moment. But it used to
> > be three, see the commit 04d2c8c83d0e3ac5f ("printk: convert the format
> > for KERN_<LEVEL> to a 2 byte pattern").
> >
> > Also I fixed the default ratelimit level. It looked very strange
> > when it was different from the default log level.
> >
> > Signed-off-by: Petr Mladek <pmladek@suse.com>
> > ---
> > fs/btrfs/super.c | 26 +++++++++++++++-----------
> > include/linux/printk.h | 2 ++
> > 2 files changed, 17 insertions(+), 11 deletions(-)
> >
> > diff --git a/fs/btrfs/super.c b/fs/btrfs/super.c
> > index 74ed5aae6cea..c083d84eaa32 100644
> > --- a/fs/btrfs/super.c
> > +++ b/fs/btrfs/super.c
> > @@ -202,27 +202,31 @@ void __btrfs_handle_fs_error(struct btrfs_fs_info *fs_info, const char *function
> > void btrfs_printk(const struct btrfs_fs_info *fs_info, const char *fmt, ...)
> > {
> > struct super_block *sb = fs_info->sb;
> > - char lvl[4];
> > + char lvl[PRINTK_MAX_SINGLE_HEADER_LEN + 1];
> > struct va_format vaf;
> > va_list args;
> > - const char *type = logtypes[4];
> > + const char *type = NULL;
> > int kern_level;
> > struct ratelimit_state *ratelimit;
>
> warning: ‘ratelimit’ may be used uninitialized in this function
>
> So this triggered my attention. It seems my gcc (4.1.2) is not smart enough
> to notice that ratelimit will be set to a default value if !type.
>
> Still, IMHO the code is too convoluted for the casual reader.
I did not see this with gcc 4.8.5. But I agree that it might
be confusing. Please, find a proposed fix below.
> > vaf.fmt = fmt;
> > diff --git a/include/linux/printk.h b/include/linux/printk.h
> > index a0859e169bc3..afe8ccec1672 100644
> > --- a/include/linux/printk.h
> > +++ b/include/linux/printk.h
> > @@ -10,6 +10,8 @@
> > extern const char linux_banner[];
> > extern const char linux_proc_banner[];
> >
> > +#define PRINTK_MAX_SINGLE_HEADER_LEN 2
>
> I think you want to use this definition instead of the hardcoded "2" in
> printk_skip_level():
>
> | static inline const char *printk_skip_level(const char *buffer)
> | {
> | if (printk_get_level(buffer))
> | return buffer + 2;
>
> return buffer + PRINTK_MAX_SINGLE_HEADER_LEN;
I do not like hardcoded constants either. But this is with sync
with the hardcoded buffer[0] and buffer[1] in printk_get_level().
PRINTK_MAX_SINGLE_HEADER_LEN is meant as the maximum length in case
of some non-standard lengths in the future. We used 3-byte headers
in the past. The name is confusing for this use case. I probably
should have avoided _MAX_ in the name. I would leave this for now.
It is well localized...
Here is the proposed fix for the warning:
>From 5b5a8f7ff4f2d5c33316e600a29d45314ac47a16 Mon Sep 17 00:00:00 2001
From: Petr Mladek <pmladek@suse.com>
Date: Tue, 13 Dec 2016 13:12:56 +0100
Subject: [PATCH] btrfs: Better handle btrfs_printk() defaults
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
The commit 262c5e86fec7cfd ("printk/btrfs: handle more message headers")
triggers:
warning: ‘ratelimit’ may be used uninitialized in this function
with gcc (4.1.2) and probably many other versions. The code actually
is correct but a bit twisted. Let's make it more straightforward
and set the default values at the beginning.
Reported-by: Geert Uytterhoeven <geert@linux-m68k.org>
Signed-off-by: Petr Mladek <pmladek@suse.com>
---
fs/btrfs/super.c | 12 +++---------
1 file changed, 3 insertions(+), 9 deletions(-)
diff --git a/fs/btrfs/super.c b/fs/btrfs/super.c
index 180f910339f4..3b713b6fcc26 100644
--- a/fs/btrfs/super.c
+++ b/fs/btrfs/super.c
@@ -202,12 +202,12 @@ void __btrfs_handle_fs_error(struct btrfs_fs_info *fs_info, const char *function
void btrfs_printk(const struct btrfs_fs_info *fs_info, const char *fmt, ...)
{
struct super_block *sb = fs_info->sb;
- char lvl[PRINTK_MAX_SINGLE_HEADER_LEN + 1];
+ char lvl[PRINTK_MAX_SINGLE_HEADER_LEN + 1] = "\0";
struct va_format vaf;
va_list args;
- const char *type = NULL;
int kern_level;
- struct ratelimit_state *ratelimit;
+ const char *type = logtypes[4];
+ struct ratelimit_state *ratelimit = &printk_limits[4];
va_start(args, fmt);
@@ -223,12 +223,6 @@ void btrfs_printk(const struct btrfs_fs_info *fs_info, const char *fmt, ...)
fmt += size;
}
- if (!type) {
- *lvl = '\0';
- type = logtypes[4];
- ratelimit = &printk_limits[4];
- }
-
vaf.fmt = fmt;
vaf.va = &args;
--
1.8.5.6
next prev parent reply other threads:[~2016-12-13 13:52 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-11-09 12:41 [PATCH v2 0/4] printk: Fixes and hardening related to KERN_CONT Petr Mladek
2016-11-09 12:41 ` [PATCH v2 1/4] printk/NMI: Handle continuous lines and missing newline Petr Mladek
2016-11-11 0:26 ` Sergey Senozhatsky
2016-11-11 17:28 ` Steven Rostedt
2016-11-11 18:07 ` Petr Mladek
2016-11-09 12:41 ` [PATCH v2 2/4] printk/kdb: Handle more message headers Petr Mladek
2016-11-11 17:35 ` Steven Rostedt
2016-11-11 18:13 ` Petr Mladek
2016-11-09 12:41 ` [PATCH v2 3/4] printk/btrfs: " Petr Mladek
2016-11-10 13:20 ` David Sterba
2016-11-11 17:41 ` Steven Rostedt
2016-11-11 18:16 ` Petr Mladek
2016-12-13 9:21 ` Geert Uytterhoeven
2016-12-13 13:52 ` Petr Mladek [this message]
2016-12-13 14:01 ` Geert Uytterhoeven
2016-12-13 14:26 ` David Sterba
2016-11-09 12:41 ` [PATCH v2 4/4] printk/sound: " Petr Mladek
2016-11-11 17:54 ` Steven Rostedt
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20161213135246.GQ3506@pathway.suse.cz \
--to=pmladek@suse.com \
--cc=akpm@linux-foundation.org \
--cc=clm@fb.com \
--cc=dsterba@suse.com \
--cc=geert@linux-m68k.org \
--cc=jason.wessel@windriver.com \
--cc=jbacik@fb.com \
--cc=joe@perches.com \
--cc=linux-kernel@vger.kernel.org \
--cc=perex@perex.cz \
--cc=rostedt@goodmis.org \
--cc=sergey.senozhatsky.work@gmail.com \
--cc=tiwai@suse.com \
--cc=torvalds@linux-foundation.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome