From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753819AbcLPRPH (ORCPT ); Fri, 16 Dec 2016 12:15:07 -0500 Received: from mx2.suse.de ([195.135.220.15]:40845 "EHLO mx2.suse.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751448AbcLPRO5 (ORCPT ); Fri, 16 Dec 2016 12:14:57 -0500 Date: Fri, 16 Dec 2016 18:14:51 +0100 From: "Luis R. Rodriguez" To: "Luis R. Rodriguez" Cc: gregkh@linuxfoundation.org, ming.lei@canonical.com, wagi@monom.org, teg@jklm.no, mchehab@osg.samsung.com, zajec5@gmail.com, linux-kernel@vger.kernel.org, markivx@codeaurora.org, stephen.boyd@linaro.org, broonie@kernel.org, zohar@linux.vnet.ibm.com, tiwai@suse.de, johannes@sipsolutions.net, chunkeey@googlemail.com, hauke@hauke-m.de, jwboyer@fedoraproject.org, dmitry.torokhov@gmail.com, dwmw2@infradead.org, jslaby@suse.com, torvalds@linux-foundation.org, luto@amacapital.net, fengguang.wu@intel.com, rpurdie@rpsys.net, j.anaszewski@samsung.com, Abhay_Salunke@dell.com, Julia.Lawall@lip6.fr, Gilles.Muller@lip6.fr, nicolas.palix@imag.fr, dhowells@redhat.com, bjorn.andersson@linaro.org, arend.vanspriel@broadcom.com, kvalo@codeaurora.org Subject: Re: [PATCH v3 4/4] p54: convert to sysdata API Message-ID: <20161216171451.GX13946@wotan.suse.de> References: <20161216114632.22559-1-mcgrof@kernel.org> <20161216114632.22559-5-mcgrof@kernel.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20161216114632.22559-5-mcgrof@kernel.org> User-Agent: Mutt/1.6.0 (2016-04-01) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, Dec 16, 2016 at 03:46:32AM -0800, Luis R. Rodriguez wrote: > diff --git a/drivers/net/wireless/intersil/p54/p54usb.c b/drivers/net/wireless/intersil/p54/p54usb.c > index 043bd1c23c19..8870d177b7d5 100644 > --- a/drivers/net/wireless/intersil/p54/p54usb.c > +++ b/drivers/net/wireless/intersil/p54/p54usb.c > @@ -959,12 +958,14 @@ static int p54u_load_firmware(struct ieee80211_hw *dev, > { > struct usb_device *udev = interface_to_usbdev(intf); > struct p54u_priv *priv = dev->priv; > + const struct drvdata_req_params req_params = { > + SYSDATA_KEEP_ASYNC(p54u_load_firmware_cb, priv), > + }; Whoops forgot to convert here due to the bikeshed, sorry thought I had compile tested the entire driver... Can send a follow up later after the other patches get reviewed. Luis