From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1750788AbdAVVsv (ORCPT ); Sun, 22 Jan 2017 16:48:51 -0500 Received: from shards.monkeyblade.net ([184.105.139.130]:55894 "EHLO shards.monkeyblade.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750703AbdAVVst (ORCPT ); Sun, 22 Jan 2017 16:48:49 -0500 Date: Sun, 22 Jan 2017 16:48:47 -0500 (EST) Message-Id: <20170122.164847.331110749082525627.davem@davemloft.net> To: leon@kernel.org Cc: geliangtang@gmail.com, yishaih@mellanox.com, netdev@vger.kernel.org, linux-rdma@vger.kernel.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH] net/mlx4: use rb_entry() From: David Miller In-Reply-To: <20170122074839.GD28570@mtr-leonro.local> References: <6c1c772de8f70113580dade04f89a377174d8c88.1484817025.git.geliangtang@gmail.com> <20170122074839.GD28570@mtr-leonro.local> X-Mailer: Mew version 6.7 on Emacs 25.1 / Mule 6.0 (HANACHIRUSATO) Mime-Version: 1.0 Content-Type: Text/Plain; charset=us-ascii Content-Transfer-Encoding: 7bit X-Greylist: Sender succeeded SMTP AUTH, not delayed by milter-greylist-4.5.12 (shards.monkeyblade.net [149.20.54.216]); Sun, 22 Jan 2017 12:49:44 -0800 (PST) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org From: Leon Romanovsky Date: Sun, 22 Jan 2017 09:48:39 +0200 > I don't understand completely the rationale behind this conversion. > rb_entry == container_of, why do we need another name for it? Because it's an annotation. Either you agree that the macro exists and it should be used in every spot where those types are being used, or you don't and therefore argue for the macro and it's usage completely.