From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752625AbdAYUZq (ORCPT ); Wed, 25 Jan 2017 15:25:46 -0500 Received: from gum.cmpxchg.org ([85.214.110.215]:39862 "EHLO gum.cmpxchg.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752206AbdAYUZn (ORCPT ); Wed, 25 Jan 2017 15:25:43 -0500 Date: Wed, 25 Jan 2017 15:25:33 -0500 From: Johannes Weiner To: "Paul E. McKenney" Cc: linux-kernel@vger.kernel.org, linux-mm@kvack.org, cl@linux.com, penberg@kernel.org, rientjes@google.com, iamjoonsoo.kim@lge.com, akpm@linux-foundation.org Subject: Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU Message-ID: <20170125202533.GA22138@cmpxchg.org> References: <20170118110731.GA15949@linux.vnet.ibm.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20170118110731.GA15949@linux.vnet.ibm.com> User-Agent: Mutt/1.7.2 (2016-11-26) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, Jan 18, 2017 at 03:07:32AM -0800, Paul E. McKenney wrote: > A group of Linux kernel hackers reported chasing a bug that resulted > from their assumption that SLAB_DESTROY_BY_RCU provided an existence > guarantee, that is, that no block from such a slab would be reallocated > during an RCU read-side critical section. Of course, that is not the > case. Instead, SLAB_DESTROY_BY_RCU only prevents freeing of an entire > slab of blocks. > > However, there is a phrase for this, namely "type safety". This commit > therefore renames SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU in order > to avoid future instances of this sort of confusion. > > Signed-off-by: Paul E. McKenney This has come up in the past, and it always proved hard to agree on a better name for it. But I like SLAB_TYPESAFE_BY_RCU the best out of all proposals, and it's much more poignant than the current name. Acked-by: Johannes Weiner