From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752625AbdAYWgB (ORCPT ); Wed, 25 Jan 2017 17:36:01 -0500 Received: from mx0b-001b2d01.pphosted.com ([148.163.158.5]:50345 "EHLO mx0a-001b2d01.pphosted.com" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1752366AbdAYWgA (ORCPT ); Wed, 25 Jan 2017 17:36:00 -0500 Date: Wed, 25 Jan 2017 14:35:56 -0800 From: "Paul E. McKenney" To: Vlastimil Babka Cc: Johannes Weiner , linux-kernel@vger.kernel.org, linux-mm@kvack.org, cl@linux.com, penberg@kernel.org, rientjes@google.com, iamjoonsoo.kim@lge.com, akpm@linux-foundation.org Subject: Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU Reply-To: paulmck@linux.vnet.ibm.com References: <20170118110731.GA15949@linux.vnet.ibm.com> <20170125202533.GA22138@cmpxchg.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: User-Agent: Mutt/1.5.21 (2010-09-15) X-TM-AS-GCONF: 00 X-Content-Scanned: Fidelis XPS MAILER x-cbid: 17012522-0020-0000-0000-00000B2EDAC9 X-IBM-SpamModules-Scores: X-IBM-SpamModules-Versions: BY=3.00006498; HX=3.00000240; KW=3.00000007; PH=3.00000004; SC=3.00000200; SDB=6.00812675; UDB=6.00396361; IPR=6.00590093; BA=6.00005090; NDR=6.00000001; ZLA=6.00000005; ZF=6.00000009; ZB=6.00000000; ZP=6.00000000; ZH=6.00000000; ZU=6.00000002; MB=3.00014048; XFM=3.00000011; UTC=2017-01-25 22:35:58 X-IBM-AV-DETECTION: SAVI=unused REMOTE=unused XFE=unused x-cbparentid: 17012522-0021-0000-0000-0000598871D4 Message-Id: <20170125223555.GM3989@linux.vnet.ibm.com> X-Proofpoint-Virus-Version: vendor=fsecure engine=2.50.10432:,, definitions=2017-01-25_16:,, signatures=0 X-Proofpoint-Spam-Details: rule=outbound_notspam policy=outbound score=0 spamscore=0 suspectscore=2 malwarescore=0 phishscore=0 adultscore=0 bulkscore=0 classifier=spam adjust=0 reason=mlx scancount=1 engine=8.0.1-1612050000 definitions=main-1701250210 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, Jan 25, 2017 at 10:26:08PM +0100, Vlastimil Babka wrote: > On 01/25/2017 09:25 PM, Johannes Weiner wrote: > >On Wed, Jan 18, 2017 at 03:07:32AM -0800, Paul E. McKenney wrote: > >>A group of Linux kernel hackers reported chasing a bug that resulted > >>from their assumption that SLAB_DESTROY_BY_RCU provided an existence > >>guarantee, that is, that no block from such a slab would be reallocated > >>during an RCU read-side critical section. Of course, that is not the > >>case. Instead, SLAB_DESTROY_BY_RCU only prevents freeing of an entire > >>slab of blocks. > >> > >>However, there is a phrase for this, namely "type safety". This commit > >>therefore renames SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU in order > >>to avoid future instances of this sort of confusion. > >> > >>Signed-off-by: Paul E. McKenney > > > >This has come up in the past, and it always proved hard to agree on a > >better name for it. But I like SLAB_TYPESAFE_BY_RCU the best out of > >all proposals, and it's much more poignant than the current name. > > Heh, until I've seen this thread I had the same wrong assumption > about the flag, so it suprised me. Good thing I didn't have a chance > to use it wrongly so far :) > > "Type safety" in this context seems quite counter-intuitive for me, > as I've only heard it to describe programming languages. But that's > fine when the name sounds so exotic that one has to look up what it > does. Much safer than when the meaning seems obvious, but in fact > it's misleading. > > Acked-by: Vlastimil Babka > > >Acked-by: Johannes Weiner Thank you both! I have added these, as well as a Not-acked-by for Eric. ;-) Thanx, Paul > >-- > >To unsubscribe, send a message with 'unsubscribe linux-mm' in > >the body to majordomo@kvack.org. For more info on Linux MM, > >see: http://www.linux-mm.org/ . > >Don't email: email@kvack.org > > >