From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751146AbdBACUt (ORCPT ); Tue, 31 Jan 2017 21:20:49 -0500 Received: from mail-pg0-f66.google.com ([74.125.83.66]:36767 "EHLO mail-pg0-f66.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750970AbdBACUs (ORCPT ); Tue, 31 Jan 2017 21:20:48 -0500 Date: Tue, 31 Jan 2017 18:20:32 -0800 From: Dmitry Torokhov To: Benjamin Herrenschmidt , Paul Mackerras Cc: Michael Ellerman , Scott Wood , Kumar Gala , Arnd Bergmann , linuxppc-dev@lists.ozlabs.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH 1/2] powerpc: make use of for_each_node_by_name() instead of open-coding it Message-ID: <20170201022032.GB17308@dtor-ws> References: <20170201015438.18826-1-dmitry.torokhov@gmail.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20170201015438.18826-1-dmitry.torokhov@gmail.com> User-Agent: Mutt/1.5.21 (2010-09-15) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, Jan 31, 2017 at 05:54:37PM -0800, Dmitry Torokhov wrote: > Instead of manually coding the loop with of_find_node_by_name(), let's > switch to the standard macro for iterating over nodes with given name. > > Signed-off-by: Dmitry Torokhov > --- > arch/powerpc/platforms/83xx/mpc832x_mds.c | 2 +- > arch/powerpc/platforms/83xx/mpc832x_rdb.c | 2 +- > arch/powerpc/platforms/83xx/mpc836x_mds.c | 2 +- > arch/powerpc/platforms/cell/interrupt.c | 3 +-- > arch/powerpc/platforms/cell/setup.c | 3 +-- > arch/powerpc/platforms/cell/spider-pic.c | 3 +-- > arch/powerpc/platforms/powermac/feature.c | 2 +- > 7 files changed, 7 insertions(+), 10 deletions(-) > > diff --git a/arch/powerpc/platforms/83xx/mpc832x_mds.c b/arch/powerpc/platforms/83xx/mpc832x_mds.c > index bb7b25acf26f..1e92f806ee60 100644 > --- a/arch/powerpc/platforms/83xx/mpc832x_mds.c > +++ b/arch/powerpc/platforms/83xx/mpc832x_mds.c > @@ -75,7 +75,7 @@ static void __init mpc832x_sys_setup_arch(void) > par_io_init(np); > of_node_put(np); > > - for (np = NULL; (np = of_find_node_by_name(np, "ucc")) != NULL;) > + for_each_node_by_name(np. "ucc") Gah, kbuild robot even told me about this typo and I missed it. Please let me know if you can fix up or if I should resend (or drop). I'd rather it not get dropped as I want to convert of_find_node_by_name() to stop dropping reference to the starting node, as half of the users do not expect it. Thanks. -- Dmitry