From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753353AbdBAQ7U (ORCPT ); Wed, 1 Feb 2017 11:59:20 -0500 Received: from mout.kundenserver.de ([212.227.17.13]:59352 "EHLO mout.kundenserver.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753137AbdBAQ7R (ORCPT ); Wed, 1 Feb 2017 11:59:17 -0500 From: Arnd Bergmann To: Steven Rostedt , Ingo Molnar Cc: Arnd Bergmann , Masami Hiramatsu , Marcin Nowakowski , linux-kernel@vger.kernel.org Subject: [PATCH] tracing/kprobes: fix __init annotation Date: Wed, 1 Feb 2017 17:57:56 +0100 Message-Id: <20170201165826.2625888-1-arnd@arndb.de> X-Mailer: git-send-email 2.9.0 X-Provags-ID: V03:K0:wOeOtb2RnCzO7sVkkSl9iPxgBv3dApBMAiUR1cLYm/0R4nGNroV 7kOJtanNKxos3Zp1MwupDuc4J/om4cbQvCiaoYtXRMtyvmHvwVpWw/chjED9rBsaXCCukla 2znE0qwLTjBn5GGWEaf6W0TVvQ6fZuMarbRN2jAvu6HjqmXn2e18596mztTAdRsDEdzZLyu 75MRF48pW5+maYzej87gg== X-UI-Out-Filterresults: notjunk:1;V01:K0:juzdhcoU3E0=:+LjnzD4CH+iZ8W0yllOzLj uHhlMg4W5lBz9PFfnCEZ+ngwYgoi2w69uYECbEfWSgEqL/RsgYpYU0Rl94Fc1ij5M+qqfAq1J zr7amU9A0VlSRlGJW/+k5dUkDiuZwF1scgimx0tP+zllWn7aLXAxlM1nzWd98zmb77HgRx+CR KkdwztedKfCoxioDjDm8xYK86e1reX6EJzcfcE5m130bLBNcUMVdDgvHR0UumsVI23D0/qI0D aDsAbFHP42dlG6oy72JCysr+cPNmHy6H0cO5ZQByiwGrTsqWnWipy5oC2HfCYNJ8/CxoHBL6O 896aYwR4+wrywGLQ/3p2T6UiOXIAV//30o1zwBay7tpst9ohetc2zDXqu+s2XlcVB20VsJxKl 8oz8MjBIVKe3DrWT25i6K4bT9uH3ouQXXCARlU/+VkFTj2JWE7JdbXeNlF68rr0diEKCTP1c3 6tMqEc9adj7hwZY7prW5W3e/X0GsjjhHHIq0AMKzaHf5+XjgAZm5Iy7/aU98ft4xAdnhuSvhC 7dQIteh2Sn6BVv7viI78XIK7ycw2iyK5tPVFgTyYYcsDQVPrk36U9MWhm1bZfVl972NMr0o64 KAKYkD/eZUHQSfh+ewN2LfcS8Tij6raoaxYfSOV7Hv7uX68HTfLKLlr+ILzS6JoQmeuX2a+dq G1RTNR12Wn+CylgK+EyOQYU2oc01PvIcu3vBo5goeB/bPhMcyYNZGAsA8P9CJmojgeYM= Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org clang complains about "__init" being attached to a struct name: kernel/trace/trace_kprobe.c:1375:15: error: '__section__' attribute only applies to functions and global variables The intention must have been to mark the function as __init instead of the type, so move the attribute there. Fixes: f18f97ac43d7 ("tracing/kprobes: Add a helper method to return number of probe hits") Signed-off-by: Arnd Bergmann --- kernel/trace/trace_kprobe.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/kernel/trace/trace_kprobe.c b/kernel/trace/trace_kprobe.c index a133ecd741e4..7ad9e53ad174 100644 --- a/kernel/trace/trace_kprobe.c +++ b/kernel/trace/trace_kprobe.c @@ -1372,7 +1372,7 @@ kprobe_trace_selftest_target(int a1, int a2, int a3, int a4, int a5, int a6) return a1 + a2 + a3 + a4 + a5 + a6; } -static struct __init trace_event_file * +static __init struct trace_event_file * find_trace_probe_file(struct trace_kprobe *tk, struct trace_array *tr) { struct trace_event_file *file; -- 2.9.0