From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752853AbdBFC1P (ORCPT ); Sun, 5 Feb 2017 21:27:15 -0500 Received: from mail.kernel.org ([198.145.29.136]:38200 "EHLO mail.kernel.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752506AbdBFC1N (ORCPT ); Sun, 5 Feb 2017 21:27:13 -0500 Date: Mon, 6 Feb 2017 11:26:53 +0900 From: Masami Hiramatsu To: Arnd Bergmann Cc: Steven Rostedt , Ingo Molnar , Masami Hiramatsu , Marcin Nowakowski , linux-kernel@vger.kernel.org Subject: Re: [PATCH] tracing/kprobes: fix __init annotation Message-Id: <20170206112653.02e74c4be25ef5358c772b0f@kernel.org> In-Reply-To: <20170201165826.2625888-1-arnd@arndb.de> References: <20170201165826.2625888-1-arnd@arndb.de> X-Mailer: Sylpheed 3.5.0 (GTK+ 2.24.30; x86_64-pc-linux-gnu) Mime-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, 1 Feb 2017 17:57:56 +0100 Arnd Bergmann wrote: > clang complains about "__init" being attached to a struct name: > > kernel/trace/trace_kprobe.c:1375:15: error: '__section__' attribute only applies to functions and global variables > > The intention must have been to mark the function as __init instead of > the type, so move the attribute there. > > Fixes: f18f97ac43d7 ("tracing/kprobes: Add a helper method to return number of probe hits") > Signed-off-by: Arnd Bergmann Looks good to me. Acked-by: Masami Hiramatsu Thanks! > --- > kernel/trace/trace_kprobe.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/kernel/trace/trace_kprobe.c b/kernel/trace/trace_kprobe.c > index a133ecd741e4..7ad9e53ad174 100644 > --- a/kernel/trace/trace_kprobe.c > +++ b/kernel/trace/trace_kprobe.c > @@ -1372,7 +1372,7 @@ kprobe_trace_selftest_target(int a1, int a2, int a3, int a4, int a5, int a6) > return a1 + a2 + a3 + a4 + a5 + a6; > } > > -static struct __init trace_event_file * > +static __init struct trace_event_file * > find_trace_probe_file(struct trace_kprobe *tk, struct trace_array *tr) > { > struct trace_event_file *file; > -- > 2.9.0 > -- Masami Hiramatsu