From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754498AbdBGTdI (ORCPT ); Tue, 7 Feb 2017 14:33:08 -0500 Received: from mx1.redhat.com ([209.132.183.28]:57964 "EHLO mx1.redhat.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752003AbdBGTcQ (ORCPT ); Tue, 7 Feb 2017 14:32:16 -0500 Date: Tue, 7 Feb 2017 11:25:05 -0800 From: Jessica Yu To: Laura Abbott Cc: Kees Cook , Jason Wessel , Jonathan Corbet , Russell King , Catalin Marinas , Will Deacon , "James E.J. Bottomley" , Helge Deller , Martin Schwidefsky , Heiko Carstens , Thomas Gleixner , Ingo Molnar , "H. Peter Anvin" , x86@kernel.org, Rob Herring , "Rafael J. Wysocki" , Len Brown , Pavel Machek , Mark Rutland , linux-doc@vger.kernel.org, linux-kernel@vger.kernel.org, linux-arm-kernel@lists.infradead.org, linux-parisc@vger.kernel.org, linux-s390@vger.kernel.org, linux-pm@vger.kernel.org, kernel-hardening@lists.openwall.com, Robin Murphy , Rusty Russell Subject: Re: arch: Rename CONFIG_DEBUG_RODATA and CONFIG_DEBUG_MODULE_RONX Message-ID: <20170207192505.m5gg6rtqgbbwtwa4@jeyu> References: <1486427518-14819-1-git-send-email-labbott@redhat.com> <1486427518-14819-3-git-send-email-labbott@redhat.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii; format=flowed Content-Disposition: inline In-Reply-To: <1486427518-14819-3-git-send-email-labbott@redhat.com> X-OS: Linux jeyu 4.7.6-100.fc23.x86_64+debug x86_64 User-Agent: NeoMutt/20161126 (1.7.1) X-Greylist: Sender IP whitelisted, not delayed by milter-greylist-4.5.16 (mx1.redhat.com [10.5.110.30]); Tue, 07 Feb 2017 19:25:09 +0000 (UTC) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org +++ Laura Abbott [06/02/17 16:31 -0800]: >Both of these options are poorly named. The features they provide are >necessary for system security and should not be considered debug only. >Change the names to CONFIG_STRICT_KERNEL_RWX and >CONFIG_STRICT_MODULE_RWX to better describe what these options do. > >Signed-off-by: Laura Abbott >--- >v3: Minor config text tweek per Kees. Corrected the change of config names in >the arm config files. >--- > Documentation/DocBook/kgdb.tmpl | 8 ++++---- > Documentation/security/self-protection.txt | 4 ++-- > arch/Kconfig | 4 ++-- > arch/arm/configs/aspeed_g4_defconfig | 4 ++-- > arch/arm/configs/aspeed_g5_defconfig | 4 ++-- > arch/arm/include/asm/cacheflush.h | 2 +- > arch/arm/kernel/patch.c | 4 ++-- > arch/arm/kernel/vmlinux.lds.S | 8 ++++---- > arch/arm/mm/Kconfig | 2 +- > arch/arm/mm/init.c | 4 ++-- > arch/arm64/Kconfig.debug | 2 +- > arch/arm64/kernel/insn.c | 2 +- > arch/parisc/configs/712_defconfig | 1 - > arch/parisc/configs/c3000_defconfig | 1 - > arch/parisc/mm/init.c | 2 +- > include/linux/filter.h | 4 ++-- > include/linux/init.h | 4 ++-- > include/linux/module.h | 2 +- > init/main.c | 4 ++-- > kernel/configs/android-recommended.config | 2 +- > kernel/module.c | 6 +++--- > kernel/power/hibernate.c | 2 +- > kernel/power/power.h | 4 ++-- > kernel/power/snapshot.c | 4 ++-- > 24 files changed, 41 insertions(+), 43 deletions(-) For the module.{c,h} bits: Acked-by: Jessica Yu