From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S933241AbdBHNOq (ORCPT ); Wed, 8 Feb 2017 08:14:46 -0500 Received: from mx2.suse.de ([195.135.220.15]:42810 "EHLO mx2.suse.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754292AbdBHNOk (ORCPT ); Wed, 8 Feb 2017 08:14:40 -0500 Date: Wed, 8 Feb 2017 13:56:53 +0100 From: Michal Hocko To: Tetsuo Handa Cc: mgorman@suse.de, linux-mm@kvack.org, vbabka@suse.cz, akpm@linux-foundation.org, linux-kernel@vger.kernel.org Subject: Re: [RFC PATCH] mm: move pcp and lru-pcp drainging into vmstat_wq Message-ID: <20170208125653.GL5686@dhcp22.suse.cz> References: <20170207210908.530-1-mhocko@kernel.org> <20170208105334.zbjuaaqwmp5rgpui@suse.de> <20170208120354.GI5686@dhcp22.suse.cz> <20170208123113.nq5unzmzpb23zoz5@suse.de> <201702082144.BCE17682.SMOFOHJOVQLtFF@I-love.SAKURA.ne.jp> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <201702082144.BCE17682.SMOFOHJOVQLtFF@I-love.SAKURA.ne.jp> User-Agent: Mutt/1.6.0 (2016-04-01) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed 08-02-17 21:44:36, Tetsuo Handa wrote: > Mel Gorman wrote: > > > > It also feels like vmstat is now a misleading name for something that > > > > handles vmstat, lru drains and per-cpu drains but that's cosmetic. > > > > > > yeah a better name sounds like a good thing. mm_nonblock_wq? > > > > > > > it's not always non-blocking. Maybe mm_percpu_wq to describev a workqueue > > that handles a variety of MM-related per-cpu updates? > > > > Why not make it global like ones created by workqueue_init_early() ? I can see alloc_workqueue_attrs in that path so we can hit the page allocator and if unlucky try to drain_all_pages. We might have more even before this. So I think we still need a check for the WQ being initialized already. I do not have a strong preference to when to allocate it. Moving the initialization out to workqueue_init_early wold mean that the WQ would have to be visible outside of the mm proper which is not ideal. We can live with that, though, so I will move it there if this is a prevalent opinion. -- Michal Hocko SUSE Labs