From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752338AbdBJKLX (ORCPT ); Fri, 10 Feb 2017 05:11:23 -0500 Received: from LGEAMRELO13.lge.com ([156.147.23.53]:34956 "EHLO lgeamrelo13.lge.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751593AbdBJKK7 (ORCPT ); Fri, 10 Feb 2017 05:10:59 -0500 X-Original-SENDERIP: 156.147.1.126 X-Original-MAILFROM: byungchul.park@lge.com X-Original-SENDERIP: 10.177.222.33 X-Original-MAILFROM: byungchul.park@lge.com Date: Fri, 10 Feb 2017 18:55:39 +0900 From: Byungchul Park To: Peter Zijlstra Cc: mingo@kernel.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH] sched: Enhance readability of iterating wake_list Message-ID: <20170210095538.GD16086@X58A-UD3R> References: <1486699771-8007-1-git-send-email-byungchul.park@lge.com> <20170210075523.GF6515@twins.programming.kicks-ass.net> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20170210075523.GF6515@twins.programming.kicks-ass.net> User-Agent: Mutt/1.5.21 (2010-09-15) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, Feb 10, 2017 at 08:55:23AM +0100, Peter Zijlstra wrote: > On Fri, Feb 10, 2017 at 01:09:31PM +0900, Byungchul Park wrote: > > +#define for_each_wake_list(task, node) \ > > + for ((task) = llist_entry((node), struct task_struct, wake_entry); \ > > + node; (node) = llist_next(node), \ > > + (task) = llist_entry((node), struct task_struct, wake_entry)) > > + > > How about you make that llist_for_each(pos, member) or similar and > replace all while (foo) { foo = llist_next(foo); } instances? > > Because most llist_next() users have the same pattern. Yes, it would be better. I will do it. Thank you.