From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753727AbdBJSE6 (ORCPT ); Fri, 10 Feb 2017 13:04:58 -0500 Received: from mail.kernel.org ([198.145.29.136]:57118 "EHLO mail.kernel.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751798AbdBJSEi (ORCPT ); Fri, 10 Feb 2017 13:04:38 -0500 Date: Fri, 10 Feb 2017 11:42:50 -0600 From: Bjorn Helgaas To: Lukas Wunner Cc: Greg Kroah-Hartman , linux-kernel@vger.kernel.org, Andreas Noever , linux-pci@vger.kernel.org, linux-pm@vger.kernel.org Subject: Re: [PATCH v5 1/8] PCI: Recognize Thunderbolt devices Message-ID: <20170210174250.GD29169@bhelgaas-glaptop.roam.corp.google.com> References: <20170128215208.GM20550@bhelgaas-glaptop.roam.corp.google.com> <20170129002616.GA28225@wunner.de> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20170129002616.GA28225@wunner.de> User-Agent: Mutt/1.5.21 (2010-09-15) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Sun, Jan 29, 2017 at 01:26:16AM +0100, Lukas Wunner wrote: > On Sat, Jan 28, 2017 at 03:52:08PM -0600, Bjorn Helgaas wrote: > > On Sun, Jan 15, 2017 at 09:03:45PM +0100, Lukas Wunner wrote: > > > +static void set_pcie_vendor_specific(struct pci_dev *dev) > > > > This is very specific to Thunderbolt, so let's name it something that > > conveys that information. The fact that we use a vendor-specific > > capability to figure it out isn't really relevant in the caller. > > I thought that we may have the necessity in the future to parse other > VSECs on device probe, so I gave the function this generic name. > > Think about it, every VSEC that needs to be parsed needs the while loop > below. It's more efficient to have only a single while loop that handles > *all* VSECs at once. > > If someone needs to parse another VSEC, they just add it to this function. > So IMO the way I've solved it is preferable to just adding a Thunderbolt- > specific function. > > Are you sure you want this renamed? (y/n) Sorry for the delay; I missed this question. If this has already been merged somewhere as-is, that's fine. If you repost it for any reason, I would prefer to rename it so it reflects the functionality rather than the source of the information. This isn't a performance path, so readability is more important than optimization. Bjorn