From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753139AbdBNJlu (ORCPT ); Tue, 14 Feb 2017 04:41:50 -0500 Received: from mail.free-electrons.com ([62.4.15.54]:42979 "EHLO mail.free-electrons.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752959AbdBNJlr (ORCPT ); Tue, 14 Feb 2017 04:41:47 -0500 From: Quentin Schulz To: knaack.h@gmx.de, lars@metafoo.de, pmeerw@pmeerw.net, robh+dt@kernel.org, mark.rutland@arm.com, wens@csie.org, sre@kernel.org, linux@armlinux.org.uk, maxime.ripard@free-electrons.com, lee.jones@linaro.org Cc: Quentin Schulz , linux-iio@vger.kernel.org, devicetree@vger.kernel.org, linux-kernel@vger.kernel.org, linux-pm@vger.kernel.org, linux-arm-kernel@lists.infradead.org, thomas.petazzoni@free-electrons.com, icenowy@aosc.xyz, bonbons@linux-vserver.org Subject: [PATCH v3 01/18] dt-bindings: power: battery: add constant-charge-current property Date: Tue, 14 Feb 2017 10:40:55 +0100 Message-Id: <20170214094112.27426-2-quentin.schulz@free-electrons.com> X-Mailer: git-send-email 2.9.3 In-Reply-To: <20170214094112.27426-1-quentin.schulz@free-electrons.com> References: <20170214094112.27426-1-quentin.schulz@free-electrons.com> Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org This adds the constant-charge-current property to the list of optional properties of the battery. The constant charge current is critical for batteries as they can't handle all charge currents. Signed-off-by: Quentin Schulz --- added in v3 Documentation/devicetree/bindings/power/supply/battery.txt | 2 ++ 1 file changed, 2 insertions(+) diff --git a/Documentation/devicetree/bindings/power/supply/battery.txt b/Documentation/devicetree/bindings/power/supply/battery.txt index d78a4aa..3e830fe 100644 --- a/Documentation/devicetree/bindings/power/supply/battery.txt +++ b/Documentation/devicetree/bindings/power/supply/battery.txt @@ -7,6 +7,7 @@ Optional Properties: - voltage-min-design-microvolt: drained battery voltage - energy-full-design-microwatt-hours: battery design energy - charge-full-design-microamp-hours: battery design capacity + - constant-charge-current-microamp: battery constant charge current Future Properties must be named for the corresponding elements in enum power_supply_property, defined in include/linux/power_supply.h. @@ -22,6 +23,7 @@ Example: voltage-min-design-microvolt = <3200000>; energy-full-design-microwatt-hours = <5290000>; charge-full-design-microamp-hours = <1430000>; + constant-charge-current-microamp = <300000>; }; charger: charger@11 { -- 2.9.3