From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754114AbdBUSiF (ORCPT ); Tue, 21 Feb 2017 13:38:05 -0500 Received: from mail.skyhub.de ([78.46.96.112]:60431 "EHLO mail.skyhub.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752203AbdBUShG (ORCPT ); Tue, 21 Feb 2017 13:37:06 -0500 From: Borislav Petkov To: "H. Peter Anvin" Cc: X86 ML , LKML Subject: [PATCH] x86/boot: Correct setup_header.start_sys name Date: Tue, 21 Feb 2017 19:36:39 +0100 Message-Id: <20170221183639.16554-1-bp@alien8.de> X-Mailer: git-send-email 2.11.0 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org From: Borislav Petkov It is called start_sys_seg elsewhere so rename it to that. It is an obsolete field so we could just as well directly call it __u16 __pad... No functionality change. Signed-off-by: Borislav Petkov --- arch/x86/include/uapi/asm/bootparam.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/arch/x86/include/uapi/asm/bootparam.h b/arch/x86/include/uapi/asm/bootparam.h index 5138dacf8bb8..07244ea16765 100644 --- a/arch/x86/include/uapi/asm/bootparam.h +++ b/arch/x86/include/uapi/asm/bootparam.h @@ -58,7 +58,7 @@ struct setup_header { __u32 header; __u16 version; __u32 realmode_swtch; - __u16 start_sys; + __u16 start_sys_seg; __u16 kernel_version; __u8 type_of_loader; __u8 loadflags; -- 2.11.0