From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1756662AbdCHCIm (ORCPT ); Tue, 7 Mar 2017 21:08:42 -0500 Received: from mail-pg0-f67.google.com ([74.125.83.67]:34678 "EHLO mail-pg0-f67.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1756577AbdCHCIk (ORCPT ); Tue, 7 Mar 2017 21:08:40 -0500 Date: Wed, 8 Mar 2017 09:39:13 +0800 From: Boqun Feng To: "Paul E. McKenney" Cc: Dmitry Vyukov , josh@joshtriplett.org, Steven Rostedt , Mathieu Desnoyers , jiangshanlai@gmail.com, LKML , syzkaller Subject: Re: rcu: WARNING in rcu_seq_end Message-ID: <20170308013913.4si2ldnomfktzedq@tardis> References: <20170306100741.GJ30506@linux.vnet.ibm.com> <20170306230800.GK30506@linux.vnet.ibm.com> <20170307142740.uh2nnaw44albn3t2@tardis> <20170307152715.GM30506@linux.vnet.ibm.com> <20170307230513.7mwnnhuqqbgsecm6@tardis> <20170307233154.GV30506@linux.vnet.ibm.com> MIME-Version: 1.0 Content-Type: multipart/signed; micalg=pgp-sha256; protocol="application/pgp-signature"; boundary="eizp6v2k3rpdgxxb" Content-Disposition: inline In-Reply-To: <20170307233154.GV30506@linux.vnet.ibm.com> User-Agent: NeoMutt/20170225 (1.8.0) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org --eizp6v2k3rpdgxxb Content-Type: text/plain; charset=us-ascii Content-Disposition: inline Content-Transfer-Encoding: quoted-printable On Tue, Mar 07, 2017 at 03:31:54PM -0800, Paul E. McKenney wrote: > On Wed, Mar 08, 2017 at 07:05:13AM +0800, Boqun Feng wrote: > > On Tue, Mar 07, 2017 at 07:27:15AM -0800, Paul E. McKenney wrote: > > > On Tue, Mar 07, 2017 at 03:43:42PM +0100, Dmitry Vyukov wrote: > > > > On Tue, Mar 7, 2017 at 3:27 PM, Boqun Feng w= rote: > > > > > On Tue, Mar 07, 2017 at 08:05:19AM +0100, Dmitry Vyukov wrote: > > > > > [...] > > > > >> >> > > > > >> >> What is that mutex? And what locks/unlocks provide synchroniz= ation? I > > > > >> >> see that one uses exp_mutex and another -- exp_wake_mutex. > > > > >> > > > > > >> > Both of them. > > > > >> > > > > > >> > ->exp_mutex is acquired by the task requesting the grace perio= d, and > > > > >> > the counter's first increment is done by that task under that = mutex. > > > > >> > This task then schedules a workqueue, which drives forward the= grace > > > > >> > period. Upon grace-period completion, the workqueue handler d= oes the > > > > >> > second increment (the one that your patch addressed). The wor= kqueue > > > > >> > handler then acquires ->exp_wake_mutex and wakes the task that= holds > > > > >> > ->exp_mutex (along with all other tasks waiting for this grace= period), > > > > >> > and that task releases ->exp_mutex, which allows the next grac= e period to > > > > >> > start (and the first increment for that next grace period to b= e carried > > > > >> > out under that lock). The workqueue handler releases ->exp_wa= ke_mutex > > > > >> > after finishing its wakeups. > > > > >> > > > > >> Then we need the following for the case when task requesting the= grace > > > > >> period does not block, right? > > > > > > > > > > Won't be necessary I think, as the smp_mb() in rcu_seq_end() and = the > > > > > smp_mb__before_atomic() in sync_exp_work_done() already provide t= he > > > > > required ordering, no? > > > >=20 > > > > smp_mb() is probably fine, but smp_mb__before_atomic() is release n= ot > > > > acquire. If we want to play that game, then I guess we also need > >=20 > > The point is that smp_mb__before_atomic() + atomic_long_inc() will > > guarantee a smp_mb() before or right along with the atomic operation, > > and that's enough because rcu_seq_done() followed by a smp_mb() will > > give it a acquire-like behavior. >=20 > Given current architectures, true enough, from what I can see. >=20 > However, let's take a look at atomic_ops.rst: >=20 >=20 > If a caller requires memory barrier semantics around an atomic_t > operation which does not return a value, a set of interfaces are > defined which accomplish this:: >=20 > void smp_mb__before_atomic(void); > void smp_mb__after_atomic(void); >=20 > For example, smp_mb__before_atomic() can be used like so:: >=20 > obj->dead =3D 1; > smp_mb__before_atomic(); > atomic_dec(&obj->ref_count); >=20 > It makes sure that all memory operations preceding the atomic_dec() > call are strongly ordered with respect to the atomic counter > operation. In the above example, it guarantees that the assignment of > "1" to obj->dead will be globally visible to other cpus before the > atomic counter decrement. >=20 > Without the explicit smp_mb__before_atomic() call, the > implementation could legally allow the atomic counter update visible > to other cpus before the "obj->dead =3D 1;" assignment. >=20 > So the ordering is guaranteed against the atomic operation, not > necessarily the stuff after it. But again, the implementations I know > of do make the guarantee, hence my calling it a theoretical bug in the > commit log. >=20 Fair enough ;-) It's me who misunderstood this part of document. However, the names of the barriers are smp_mb__{before,after}_atomic(), so if they, semantically, only provide ordering for the corresponding atomic ops rather than a full barrier, I would their names are misleading ;-) > > > > smp_mb__after_atomic() there. But it would be way easier to underst= and > >=20 > > Adding smp_mb__after_atomic() would be pointless as it's the load of=20 > > ->expedited_sequence that we want to ensure having acquire behavior > > rather than the atomic increment of @stat. >=20 > Again, agreed given current code, but atomic_ops.rst doesn't guarantee > ordering past the actual atomic operation itself. >=20 Neither does atomic_ops.rst guarantee the ordering between a load before the atomic op and memory accesses after the atomic op, right? I.e. atomic_ops.rst doesn't say no for reordering like this: r1 =3D READ_ONCE(a); ---------+ atomic_long_inc(b); | =20 smp_mb__after_atomic(); | WRITE_ONCE(c); | {r1 =3D READ_ONCE(a)} <-------+ =09 So it's still not an acquire for READ_ONCE(a), in our case "a" is ->expedited_sequence. To me, we can either fix the atomic_ops.rst or, as I proposed, just change smp_mb__before_atomic() to smp_mb(). Thoughts? Regards, Boqun > Thanx, Paul >=20 > > > > what's happens there and prove that it's correct, if we use > > > > store_release/load_acquire. > > >=20 > > > Fair point, how about the following? > > >=20 > > > Thanx, Paul > > >=20 > > > ---------------------------------------------------------------------= --- > > >=20 > > > commit 6fd8074f1976596898e39f5b7ea1755652533906 > > > Author: Paul E. McKenney > > > Date: Tue Mar 7 07:21:23 2017 -0800 > > >=20 > > > rcu: Add smp_mb__after_atomic() to sync_exp_work_done() > > > =20 > > > The sync_exp_work_done() function needs to fully order the counte= r-check > > > operation against anything happening after the corresponding grac= e period. > > > This is a theoretical bug, as all current architectures either pr= ovide > > > full ordering for atomic operation on the one hand or implement, > > > however, a little future-proofing is a good thing. This commit > > > therefore adds smp_mb__after_atomic() after the atomic_long_inc() > > > in sync_exp_work_done(). > > > =20 > > > Reported-by: Dmitry Vyukov > > > Signed-off-by: Paul E. McKenney > > >=20 > > > diff --git a/kernel/rcu/tree_exp.h b/kernel/rcu/tree_exp.h > > > index 027e123d93c7..652071abd9b4 100644 > > > --- a/kernel/rcu/tree_exp.h > > > +++ b/kernel/rcu/tree_exp.h > > > @@ -247,6 +247,7 @@ static bool sync_exp_work_done(struct rcu_state *= rsp, atomic_long_t *stat, > > > /* Ensure test happens before caller kfree(). */ > > > smp_mb__before_atomic(); /* ^^^ */ > > > atomic_long_inc(stat); > > > + smp_mb__after_atomic(); /* ^^^ */ > >=20 > > If we really care about future-proofing, I think it's more safe to > > change smp_mb__before_atomic() to smp_mb() rather than adding > > __after_atomic() barrier. Though I think both would be unnecessary ;-) > >=20 > > Regards, > > Boqun > >=20 > > > return true; > > > } > > > return false; > > >=20 >=20 >=20 --eizp6v2k3rpdgxxb Content-Type: application/pgp-signature; name="signature.asc" -----BEGIN PGP SIGNATURE----- iQEzBAABCAAdFiEEj5IosQTPz8XU1wRHSXnow7UH+rgFAli/YL4ACgkQSXnow7UH +rgEIgf/VxgbSCAY+KMb4u0PfzLKKXNRpBR1A5LBHB4rgrIBUWzyVN8o827UXNzK J88/Ku5x7FudPceFHvJbASdyh3N1AesOf/vEJucWExkO1UVfIA/mH4r1gz4VuiPH dWtwxKl8XrSH9O8O639IbVTupDeax23gsGt/GltDzgE9Nr9QuSc0EeL/kQnjrtOy KNmEljU6+z2aYwv9n4oWTMW/XZIBaR9uKnxiAp74LGxl0k4sH+LtjVoYpMnl2Vmy LEIKlhA+7gp3HuwiMgEqgdCEv8mMJmAR9H6qDv0mEmkWQ4YRW9bbus7X+LKA/Ts4 4BOSIoatrOfxzx6TfjVnsz1eEiY6jw== =bdwp -----END PGP SIGNATURE----- --eizp6v2k3rpdgxxb--