From: Jonathan Woithe <jwoithe@just42.net>
To: Micha?? K??pie?? <kernel@kempniu.pl>
Cc: Darren Hart <dvhart@infradead.org>,
Andy Shevchenko <andy@infradead.org>,
platform-driver-x86@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 03/11] platform/x86: fujitsu-laptop: merge set_lcd_level_alt() into set_lcd_level()
Date: Fri, 7 Apr 2017 21:33:35 +0930 [thread overview]
Message-ID: <20170407120335.GC15240@marvin.atrad.com.au> (raw)
In-Reply-To: <20170407115347.GB15240@marvin.atrad.com.au>
On Fri, Apr 07, 2017 at 09:23:47PM +0930, I wrote:
> On Wed, Apr 05, 2017 at 08:49:02AM +0200, Micha?? K??pie?? wrote:
> > diff --git a/drivers/platform/x86/fujitsu-laptop.c b/drivers/platform/x86/fujitsu-laptop.c
> > index 59107a599d22..2f563aa00592 100644
> > --- a/drivers/platform/x86/fujitsu-laptop.c
> > +++ b/drivers/platform/x86/fujitsu-laptop.c
> > @@ -360,41 +360,26 @@ static int set_lcd_level(int level)
> > {
> > acpi_status status = AE_OK;
> > acpi_handle handle = NULL;
> > -
> > - vdbg_printk(FUJLAPTOP_DBG_TRACE, "set lcd level via SBLL [%d]\n",
> > - level);
> > -
> > - if (level < 0 || level >= fujitsu_bl->max_brightness)
> > - return -EINVAL;
> > -
> > - status = acpi_get_handle(fujitsu_bl->acpi_handle, "SBLL", &handle);
> > - if (ACPI_FAILURE(status)) {
> > - vdbg_printk(FUJLAPTOP_DBG_ERROR, "SBLL not present\n");
> > - return -ENODEV;
> > + char *method;
> > +
> > + switch (use_alt_lcd_levels) {
> > + case 1:
> > + method = "SBL2";
> > + break;
> > + default:
> > + method = "SBLL";
> > + break;
> > }
>
> This is not necessary something actionable, but I am wondering about the
> rationale of using a switch statement here given that there really are only
> two options. In my mind at least a simple "if" clause would be clearer and
> easier to read (with or without the braces):
>
> if (use_alt_lcd_levels) {
> method = "SBL2";
> } else {
> method = "SBLL";
> }
Ah, the reason for the use of the switch was to prepare the way for patch
06/11 which adds an autodetection value to the definition of
use_alt_lcd_levels. All good.
Regards
jonathan
next prev parent reply other threads:[~2017-04-07 12:04 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-04-05 6:48 [PATCH v2 00/11] fujitsu-laptop: backlight cleanup Michał Kępień
2017-04-05 6:49 ` [PATCH v2 01/11] platform/x86: fujitsu-laptop: only handle backlight when appropriate Michał Kępień
2017-04-05 6:49 ` [PATCH v2 02/11] platform/x86: fujitsu-laptop: switch to a managed backlight device Michał Kępień
2017-04-05 6:49 ` [PATCH v2 03/11] platform/x86: fujitsu-laptop: merge set_lcd_level_alt() into set_lcd_level() Michał Kępień
2017-04-07 11:53 ` Jonathan Woithe
2017-04-07 12:03 ` Jonathan Woithe [this message]
2017-04-05 6:49 ` [PATCH v2 04/11] platform/x86: fujitsu-laptop: simplify set_lcd_level() Michał Kępień
2017-04-05 6:49 ` [PATCH v2 05/11] platform/x86: fujitsu-laptop: sync brightness in set_lcd_level() Michał Kępień
2017-04-05 6:49 ` [PATCH v2 06/11] platform/x86: fujitsu-laptop: clean up use_alt_lcd_levels handling Michał Kępień
2017-04-05 6:49 ` [PATCH v2 07/11] platform/x86: fujitsu-laptop: make disable_brightness_adjust a boolean Michał Kępień
2017-04-05 6:49 ` [PATCH v2 08/11] platform/x86: fujitsu-laptop: ignore errors when setting backlight power Michał Kępień
2017-04-05 6:49 ` [PATCH v2 09/11] platform/x86: fujitsu-laptop: do not log set_lcd_level() failures in bl_update_status() Michał Kępień
2017-04-05 6:49 ` [PATCH v2 10/11] platform/x86: fujitsu-laptop: account for backlight power when determining brightness Michał Kępień
2017-04-05 6:49 ` [PATCH v2 11/11] platform/x86: fujitsu-laptop: remove redundant fields from struct fujitsu_bl Michał Kępień
2017-04-05 15:36 ` [PATCH v2 00/11] fujitsu-laptop: backlight cleanup Darren Hart
2017-04-05 19:55 ` Michał Kępień
2017-04-06 0:45 ` Jonathan Woithe
2017-04-06 3:07 ` Darren Hart
2017-04-07 12:11 ` Jonathan Woithe
2017-04-07 17:57 ` Darren Hart
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20170407120335.GC15240@marvin.atrad.com.au \
--to=jwoithe@just42.net \
--cc=andy@infradead.org \
--cc=dvhart@infradead.org \
--cc=kernel@kempniu.pl \
--cc=linux-kernel@vger.kernel.org \
--cc=platform-driver-x86@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome