From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1756023AbdDRIYk (ORCPT ); Tue, 18 Apr 2017 04:24:40 -0400 Received: from mail-pf0-f196.google.com ([209.85.192.196]:35064 "EHLO mail-pf0-f196.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752481AbdDRIYP (ORCPT ); Tue, 18 Apr 2017 04:24:15 -0400 From: Chewie Lin To: greg@kroah.com, forest@alittletooquiet.net, devel@driverdev.osuosl.org, linux-kernel@vger.kernel.org Subject: [PATCH 1/1] drivers/staging/vt6656/main_usb.c: usb_device_reset Date: Tue, 18 Apr 2017 01:24:37 -0700 Message-Id: <20170418082437.25451-2-linsh@oregonstate.edu> X-Mailer: git-send-email 2.12.2 In-Reply-To: <20170418082437.25451-1-linsh@oregonstate.edu> References: <20170418082437.25451-1-linsh@oregonstate.edu> Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Removed the usb_device_reset(), replace with call to usb_reset_device() directly. Plus it removes the confusing function name and addressed the checkpatch warning as well by swap string in the dev_warn() call with __func__ argument, instead of explicitly calling the function name in the string: WARNING: Prefer using "%s", __func__ to embedded function names #417: FILE: main_usb.c:417: + "usb_device_reset fail status=%d\n", status); total: 0 errors, 1 warnings, 1058 lines checked And after fix: main_usb.c has no obvious style problems and is ready for submission. Signed-off-by: Chewie Lin --- drivers/staging/vt6656/main_usb.c | 15 ++++----------- 1 file changed, 4 insertions(+), 11 deletions(-) diff --git a/drivers/staging/vt6656/main_usb.c b/drivers/staging/vt6656/main_usb.c index 9e074e9daf4e..028f54b453d0 100644 --- a/drivers/staging/vt6656/main_usb.c +++ b/drivers/staging/vt6656/main_usb.c @@ -407,16 +407,6 @@ static void vnt_free_rx_bufs(struct vnt_private *priv) } } -static void usb_device_reset(struct vnt_private *priv) -{ - int status; - - status = usb_reset_device(priv->usb); - if (status) - dev_warn(&priv->usb->dev, - "usb_device_reset fail status=%d\n", status); -} - static void vnt_free_int_bufs(struct vnt_private *priv) { kfree(priv->int_buf.data_buf); @@ -995,7 +985,10 @@ vt6656_probe(struct usb_interface *intf, const struct usb_device_id *id) SET_IEEE80211_DEV(priv->hw, &intf->dev); - usb_device_reset(priv); + rc = usb_reset_device(priv->usb); + if (rc) + dev_warn(&priv->usb->dev, + "%s reset fail status=%d\n", __func__, rc); clear_bit(DEVICE_FLAGS_DISCONNECTED, &priv->flags); vnt_reset_command_timer(priv); -- 2.12.2