From: Christoph Hellwig <hch@lst.de>
To: Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
Amir Goldstein <amir73il@gmail.com>,
linux-fsdevel@vger.kernel.org
Cc: Shaohua Li <shli@kernel.org>,
Dan Williams <dan.j.williams@intel.com>,
David Howells <dhowells@redhat.com>,
Steven Whitehouse <swhiteho@redhat.com>,
Mimi Zohar <zohar@linux.vnet.ibm.com>,
linux-xfs@vger.kernel.org, linux-raid@vger.kernel.org,
linux-nvdimm@ml01.01.org, linux-kernel@vger.kernel.org
Subject: [PATCH 13/16] block: remove blk_part_pack_uuid
Date: Wed, 10 May 2017 20:02:11 +0200 [thread overview]
Message-ID: <20170510180214.16852-14-hch@lst.de> (raw)
In-Reply-To: <20170510180214.16852-1-hch@lst.de>
This helper was only used by IMA of all things, which would get spurious
errors if CONFIG_BLOCK is disabled. Just opencode the call there.
Signed-off-by: Christoph Hellwig <hch@lst.de>
---
include/linux/genhd.h | 11 -----------
security/integrity/ima/ima_policy.c | 6 ++----
2 files changed, 2 insertions(+), 15 deletions(-)
diff --git a/include/linux/genhd.h b/include/linux/genhd.h
index acff9437e5c3..e619fae2f037 100644
--- a/include/linux/genhd.h
+++ b/include/linux/genhd.h
@@ -219,12 +219,6 @@ static inline struct gendisk *part_to_disk(struct hd_struct *part)
return NULL;
}
-static inline int blk_part_pack_uuid(const u8 *uuid_str, u8 *to)
-{
- uuid_be_to_bin(uuid_str, (uuid_be *)to);
- return 0;
-}
-
static inline int disk_max_parts(struct gendisk *disk)
{
if (disk->flags & GENHD_FL_EXT_DEVT)
@@ -736,11 +730,6 @@ static inline dev_t blk_lookup_devt(const char *name, int partno)
dev_t devt = MKDEV(0, 0);
return devt;
}
-
-static inline int blk_part_pack_uuid(const u8 *uuid_str, u8 *to)
-{
- return -EINVAL;
-}
#endif /* CONFIG_BLOCK */
#endif /* _LINUX_GENHD_H */
diff --git a/security/integrity/ima/ima_policy.c b/security/integrity/ima/ima_policy.c
index 3ab1067db624..4d1178610145 100644
--- a/security/integrity/ima/ima_policy.c
+++ b/security/integrity/ima/ima_policy.c
@@ -717,10 +717,8 @@ static int ima_parse_rule(char *rule, struct ima_rule_entry *entry)
break;
}
- result = blk_part_pack_uuid(args[0].from,
- entry->fsuuid);
- if (!result)
- entry->flags |= IMA_FSUUID;
+ uuid_to_bin(args[0].from, (uuid_t *)entry->fsuuid);
+ entry->flags |= IMA_FSUUID;
break;
case Opt_uid_gt:
case Opt_euid_gt:
--
2.11.0
next prev parent reply other threads:[~2017-05-10 18:05 UTC|newest]
Thread overview: 29+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-05-10 18:01 cleanup UUID types Christoph Hellwig
2017-05-10 18:01 ` [PATCH 01/16] xfs: use uuid_copy() helper to abstract uuid_t Christoph Hellwig
2017-05-10 18:02 ` [PATCH 02/16] xfs: use uuid_be to implement the uuid_t type Christoph Hellwig
2017-05-10 18:02 ` [PATCH 03/16] uuid: rename uuid types Christoph Hellwig
2017-05-10 19:15 ` Amir Goldstein
2017-05-11 7:59 ` Christoph Hellwig
2017-05-11 8:31 ` Amir Goldstein
2017-05-10 18:02 ` [PATCH 04/16] uuid: don't export guid_index and uuid_index Christoph Hellwig
2017-05-10 18:02 ` [PATCH 05/16] uuid: add the v1 layout to uuid_t Christoph Hellwig
2017-05-11 11:40 ` Andy Shevchenko
2017-05-11 12:07 ` Christoph Hellwig
2017-05-10 18:02 ` [PATCH 06/16] afs: switch to use uuid_t and uuid_gen Christoph Hellwig
2017-05-10 18:02 ` [PATCH 07/16] uuid: remove struct uuid_v1 Christoph Hellwig
2017-05-10 18:02 ` [PATCH 08/16] xfs: remove uuid_getnodeuniq and xfs_uu_t Christoph Hellwig
2017-05-10 18:02 ` [PATCH 09/16] md: namespace private helper names Christoph Hellwig
2017-05-10 18:02 ` [PATCH 10/16] uuid: hoist helpers uuid_equal() and uuid_copy() from xfs Christoph Hellwig
2017-05-10 18:02 ` [PATCH 11/16] uuid: hoist uuid_is_null() helper from libnvdimm Christoph Hellwig
2017-05-10 18:02 ` [PATCH 12/16] xfs: use the common helper uuid_is_null() Christoph Hellwig
2017-05-10 18:02 ` Christoph Hellwig [this message]
2017-05-10 18:02 ` [PATCH 14/16] block: remove blk_part_pack_uuid Christoph Hellwig
2017-05-10 18:09 ` Christoph Hellwig
2017-05-10 18:02 ` [PATCH 15/16] ima/policy: switch to use uuid_t Christoph Hellwig
2017-05-10 18:02 ` [PATCH 16/16] fs: switch ->s_uuid to uuid_t Christoph Hellwig
2017-05-10 19:08 ` Amir Goldstein
2017-05-11 7:58 ` Christoph Hellwig
2017-05-10 18:20 ` [PATCH 03/16] uuid: rename uuid types David Howells
2017-05-11 11:38 ` Andy Shevchenko
2017-05-10 18:21 ` [PATCH 05/16] uuid: add the v1 layout to uuid_t David Howells
2017-05-10 18:22 ` [PATCH 06/16] afs: switch to use uuid_t and uuid_gen David Howells
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20170510180214.16852-14-hch@lst.de \
--to=hch@lst.de \
--cc=amir73il@gmail.com \
--cc=andriy.shevchenko@linux.intel.com \
--cc=dan.j.williams@intel.com \
--cc=dhowells@redhat.com \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-nvdimm@ml01.01.org \
--cc=linux-raid@vger.kernel.org \
--cc=linux-xfs@vger.kernel.org \
--cc=shli@kernel.org \
--cc=swhiteho@redhat.com \
--cc=zohar@linux.vnet.ibm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®