From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753311AbdEPNVf (ORCPT ); Tue, 16 May 2017 09:21:35 -0400 Received: from mx2.suse.de ([195.135.220.15]:51244 "EHLO mx1.suse.de" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1752828AbdEPNVe (ORCPT ); Tue, 16 May 2017 09:21:34 -0400 Date: Tue, 16 May 2017 15:21:32 +0200 From: Michal Hocko To: Daniel Vetter Cc: dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org, linux-mm@kvack.org, Daniel Vetter , Jani Nikula , Sean Paul , David Airlie Subject: Re: [PATCH] drm: use kvmalloc_array for drm_malloc* Message-ID: <20170516132132.GJ2481@dhcp22.suse.cz> References: <20170516090606.5891-1-mhocko@kernel.org> <20170516092230.pzadndxm5gq4i4h6@phenom.ffwll.local> <20170516095254.GG2481@dhcp22.suse.cz> <20170516130856.hvq62uuq6wmnhvpg@phenom.ffwll.local> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20170516130856.hvq62uuq6wmnhvpg@phenom.ffwll.local> User-Agent: Mutt/1.5.23 (2014-03-12) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue 16-05-17 15:08:56, Daniel Vetter wrote: > On Tue, May 16, 2017 at 11:52:55AM +0200, Michal Hocko wrote: > > On Tue 16-05-17 11:22:30, Daniel Vetter wrote: > > > On Tue, May 16, 2017 at 11:06:06AM +0200, Michal Hocko wrote: > > > > From: Michal Hocko > > > > > > > > drm_malloc* has grown their own kmalloc with vmalloc fallback > > > > implementations. MM has grown kvmalloc* helpers in the meantime. Let's > > > > use those because it a) reduces the code and b) MM has a better idea > > > > how to implement fallbacks (e.g. do not vmalloc before kmalloc is tried > > > > with __GFP_NORETRY). > > > > > > > > Signed-off-by: Michal Hocko > > > > > > Shouldn't we go one step further and just remove these wrappers, maybe > > > with cocci? > > > > my cocci sucks... > > > > > Especially drm_malloc_gfp is surpremely pointless after this > > > patch (and drm_malloc_ab probably not that useful either). > > > > So what about the following instead? It passes allyesconfig compilation. > > Yeah, looks good, but perhaps rebased onto your first patch. That way we > split the functional change from the refactor (not the first time innocent > looking changes in i915 gem code resulted in surprises). OK, I will split it. > Your patch also seems to need some stuff from -rc1, and atm drm-misc is > still pre-rc1, so I'll pull both patches in once that's sorted (I can do > the rebase myself, since it's rather trivial). But pls remind me in case > it falls through the cracks and isn't in linux-next by end of this week > :-) I have based it on top of the current linux next (next-20170516). Let me know if other tree is more appropriate. -- Michal Hocko SUSE Labs