From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1757004AbdESUgb (ORCPT ); Fri, 19 May 2017 16:36:31 -0400 Received: from outbound-smtp09.blacknight.com ([46.22.139.14]:35272 "EHLO outbound-smtp09.blacknight.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1756692AbdESUgN (ORCPT ); Fri, 19 May 2017 16:36:13 -0400 Date: Fri, 19 May 2017 21:28:43 +0100 From: Mel Gorman To: Zi Yan Cc: Anshuman Khandual , n-horiguchi@ah.jp.nec.com, kirill.shutemov@linux.intel.com, linux-kernel@vger.kernel.org, linux-mm@kvack.org, akpm@linux-foundation.org, minchan@kernel.org, vbabka@suse.cz, mhocko@kernel.org, dnellans@nvidia.com Subject: Re: [PATCH v5 02/11] mm: mempolicy: add queue_pages_node_check() Message-ID: <20170519202843.lco2rkkivh2a433k@techsingularity.net> References: <20170420204752.79703-1-zi.yan@sent.com> <20170420204752.79703-3-zi.yan@sent.com> <16799a52-8a03-7099-5f95-3016808ae65f@linux.vnet.ibm.com> <20170519160205.hkte6tlw26lfn74h@techsingularity.net> <35E3E5BA-2745-4710-A348-B6E5D892DA27@cs.rutgers.edu> MIME-Version: 1.0 Content-Type: text/plain; charset=iso-8859-15 Content-Disposition: inline In-Reply-To: <35E3E5BA-2745-4710-A348-B6E5D892DA27@cs.rutgers.edu> User-Agent: Mutt/1.6.2 (2016-07-01) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, May 19, 2017 at 12:37:38PM -0400, Zi Yan wrote: > > As you say, there is no functional change but the helper name is vague > > and gives no hint to what's it's checking for. It's somewhat tolerable as > > it is as it's obvious what is being checked but the same is not true with > > the helper name. > > > > Does queue_pages_invert_nodemask_check() work? I can change the helper name > in the next version. > Not particularly, maybe queue_pages_required and invert the check with a comment above it explaining what it's checking for would be ok. -- Mel Gorman SUSE Labs