From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1756746AbdESVjS (ORCPT ); Fri, 19 May 2017 17:39:18 -0400 Received: from outbound-smtp03.blacknight.com ([81.17.249.16]:37083 "EHLO outbound-smtp03.blacknight.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755702AbdESVjP (ORCPT ); Fri, 19 May 2017 17:39:15 -0400 Date: Fri, 19 May 2017 22:39:12 +0100 From: Mel Gorman To: Zi Yan Cc: Anshuman Khandual , n-horiguchi@ah.jp.nec.com, kirill.shutemov@linux.intel.com, linux-kernel@vger.kernel.org, linux-mm@kvack.org, akpm@linux-foundation.org, minchan@kernel.org, vbabka@suse.cz, mhocko@kernel.org, dnellans@nvidia.com Subject: Re: [PATCH v5 02/11] mm: mempolicy: add queue_pages_node_check() Message-ID: <20170519213912.xm6zuucby3h6ne6r@techsingularity.net> References: <20170420204752.79703-1-zi.yan@sent.com> <20170420204752.79703-3-zi.yan@sent.com> <16799a52-8a03-7099-5f95-3016808ae65f@linux.vnet.ibm.com> <20170519160205.hkte6tlw26lfn74h@techsingularity.net> <35E3E5BA-2745-4710-A348-B6E5D892DA27@cs.rutgers.edu> <20170519202843.lco2rkkivh2a433k@techsingularity.net> <61FCE04A-0227-4D5E-92E5-81EA06979FD3@cs.rutgers.edu> MIME-Version: 1.0 Content-Type: text/plain; charset=iso-8859-15 Content-Disposition: inline In-Reply-To: <61FCE04A-0227-4D5E-92E5-81EA06979FD3@cs.rutgers.edu> User-Agent: Mutt/1.6.2 (2016-07-01) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, May 19, 2017 at 04:48:54PM -0400, Zi Yan wrote: > On 19 May 2017, at 16:28, Mel Gorman wrote: > > > On Fri, May 19, 2017 at 12:37:38PM -0400, Zi Yan wrote: > >>> As you say, there is no functional change but the helper name is vague > >>> and gives no hint to what's it's checking for. It's somewhat tolerable as > >>> it is as it's obvious what is being checked but the same is not true with > >>> the helper name. > >>> > >> > >> Does queue_pages_invert_nodemask_check() work? I can change the helper name > >> in the next version. > >> > > > > Not particularly, maybe queue_pages_required and invert the check with a > > comment above it explaining what it's checking for would be ok. > > > > queue_pages_required() is too broad, I'm somewhat amused that you'd complain that "required" is too broad while thinking "check" is somehow self-explanatory. > I would take queue_pages_page_nid_check() > and invert the check with a comment above saying > > /* > * Check if the page's nid is in qp->nmask. > * > * If MPOL_MF_INVERT is set in qp->flags, check if the nid is > * in the invert of qp->nmask. > */ > > Does it work? > I still don't like the name but I also am not interested in debating it further for something so small. Add the comment, it's better than nothing. -- Mel Gorman SUSE Labs