From: Jessica Yu <jeyu@redhat.com>
To: Wanlong Gao <gaowanlong@huawei.com>
Cc: Xie XiuQi <xiexiuqi@huawei.com>,
akpm@linux-foundation.org, linux-kernel@vger.kernel.org,
rusty@rustcorp.com.au, john.wanghui@huawei.com,
wencongyang2@huawei.com, guijianfeng@huawei.com
Subject: Re: [PATCH] modpost: abort if a module name is too long
Date: Tue, 30 May 2017 20:30:44 -0700 [thread overview]
Message-ID: <20170531033042.mtrmcj6odvn2bmxs@jeyu> (raw)
In-Reply-To: <ff13b209-425e-def2-fae2-f8d257b52187@huawei.com>
+++ Wanlong Gao [31/05/17 10:23 +0800]:
>Hi Jessica,
>
>On 2017/5/29 17:10, Jessica Yu wrote:
>> +++ Xie XiuQi [20/05/17 15:46 +0800]:
>>> From: Wanlong Gao <gaowanlong@huawei.com>
>>>
>>> Module name has a limited length, but currently the build system
>>> allows the build finishing even if the module name is too long.
>>>
>>> CC /root/kprobe_example/abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyz.mod.o
>>> /root/kprobe_example/abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyz.mod.c:9:2:
>>> warning: initializer-string for array of chars is too long [enabled by default]
>>> .name = KBUILD_MODNAME,
>>> ^
>>>
>>> but it's merely a warning.
>>>
>>> This patch adds the check of the module name length in modpost and stops
>>> the build properly.
>>>
>>> Signed-off-by: Wanlong Gao <gaowanlong@huawei.com>
>>> Signed-off-by: Xie XiuQi <xiexiuqi@huawei.com>
>>> ---
>>> scripts/mod/modpost.c | 11 +++++++++++
>>> 1 file changed, 11 insertions(+)
>>>
>>> diff --git a/scripts/mod/modpost.c b/scripts/mod/modpost.c
>>> index 30d752a..db11c57 100644
>>> --- a/scripts/mod/modpost.c
>>> +++ b/scripts/mod/modpost.c
>>> @@ -2166,6 +2166,17 @@ static int add_versions(struct buffer *b, struct module *mod)
>>> {
>>> struct symbol *s, *exp;
>>> int err = 0;
>>> + const char *mod_name;
>>> +
>>> + mod_name = strrchr(mod->name, '/');
>>> + if (mod_name == NULL)
>>> + mod_name = mod->name;
>>> + else
>>> + mod_name++;
>>> + if (strlen(mod_name) >= MODULE_NAME_LEN) {
>>> + merror("module name is too long [%s.ko]\n", mod->name);
>>> + return 1;
>>> + }
>>
>> Hi Xie,
>>
>> This check shouldn't be in add_versions() (which does something else entirely),
>> it should probably be put in a separate helper function called from main. But
>> I'm not a big fan of the extra string manipulation to do something this simple.
>>
>> I think this check can be vastly simplified, how about something like the
>> following?
>
>This looks better, would you apply your following patch?
>
>Reviewed-by: Wanlong Gao <gaowanlong@huawei.com>
>Tested-by: Wanlong Gao <gaowanlong@huawei.com>
Sure, thanks for testing. I'll go ahead and format this into a proper
patch and resend.
Jessica
>>
>> diff --git a/scripts/mod/modpost.c b/scripts/mod/modpost.c
>> index 48397fe..bb09fc7 100644
>> --- a/scripts/mod/modpost.c
>> +++ b/scripts/mod/modpost.c
>> @@ -2139,6 +2139,9 @@ static void add_header(struct buffer *b, struct module *mod)
>> "#endif\n");
>> buf_printf(b, "\t.arch = MODULE_ARCH_INIT,\n");
>> buf_printf(b, "};\n");
>> + buf_printf(b, "\n");
>> + buf_printf(b, "static void __attribute__((section(\".discard\"), used)) __modname_test(void)\n");
>> + buf_printf(b, "{ BUILD_BUG_ON(sizeof(KBUILD_MODNAME) > MODULE_NAME_LEN); }\n");
>> }
>>
>> static void add_intree_flag(struct buffer *b, int is_intree)
>>
>> This simply checks if KBUILD_MODNAME > MODULE_NAME_LEN and breaks the build if
>> it does.
>>
>> Jessica
>>
>>> for (s = mod->unres; s; s = s->next) {
>>> exp = find_symbol(s->name);
>>> --
>>> 1.8.3.1
>>>
>>
>> .
>>
>
next prev parent reply other threads:[~2017-05-31 3:30 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-05-20 7:46 Xie XiuQi
2017-05-25 6:11 ` Wanlong Gao
2017-05-27 1:27 ` Rusty Russell
2017-05-29 9:10 ` Jessica Yu
2017-05-31 2:23 ` Wanlong Gao
2017-05-31 3:30 ` Jessica Yu [this message]
2017-05-31 3:39 ` Wanlong Gao
2017-05-31 3:48 ` Wanlong Gao
2017-06-01 11:51 ` Wanlong Gao
2017-06-01 23:23 ` Jessica Yu
2017-06-02 3:04 ` Wanlong Gao
2017-06-02 3:44 ` Wanlong Gao
2017-06-05 2:09 ` Jessica Yu
2017-06-06 1:07 ` Wanlong Gao
2017-06-07 3:41 ` Jessica Yu
2017-06-21 16:09 ` Jessica Yu
2017-06-22 1:11 ` Wanlong Gao
2017-06-22 14:25 ` Jessica Yu
2017-06-22 14:57 ` Wanlong Gao
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20170531033042.mtrmcj6odvn2bmxs@jeyu \
--to=jeyu@redhat.com \
--cc=akpm@linux-foundation.org \
--cc=gaowanlong@huawei.com \
--cc=guijianfeng@huawei.com \
--cc=john.wanghui@huawei.com \
--cc=linux-kernel@vger.kernel.org \
--cc=rusty@rustcorp.com.au \
--cc=wencongyang2@huawei.com \
--cc=xiexiuqi@huawei.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®