From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751305AbdFEO3T (ORCPT ); Mon, 5 Jun 2017 10:29:19 -0400 Received: from ozlabs.org ([103.22.144.67]:57701 "EHLO ozlabs.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751112AbdFEO3S (ORCPT ); Mon, 5 Jun 2017 10:29:18 -0400 Date: Tue, 6 Jun 2017 00:29:14 +1000 From: Stephen Rothwell To: Andy Shevchenko Cc: Christoph Hellwig , Linus Torvalds , linux-kernel@vger.kernel.org Subject: Re: new tree for linux-next: uuid Message-ID: <20170606002914.695e9c0b@canb.auug.org.au> In-Reply-To: <1496671605.22624.2.camel@linux.intel.com> References: <20170604201413.GA12748@lst.de> <20170605094956.069d5af3@canb.auug.org.au> <20170605080713.GA22028@lst.de> <1496671605.22624.2.camel@linux.intel.com> MIME-Version: 1.0 Content-Type: text/plain; charset=UTF-8 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Content-Transfer-Encoding: 8bit X-MIME-Autoconverted: from quoted-printable to 8bit by mail.home.local id v55ETO4D018548 Hi Andy, On Mon, 05 Jun 2017 17:06:45 +0300 Andy Shevchenko wrote: > > On Mon, 2017-06-05 at 10:07 +0200, Christoph Hellwig wrote: > > Meh, thanks.  This has been throught the buildbot countless times > > without a report.  But I guess a less generic name might be a good > > idea to start with. > > > > Andy: do you think UUID_INIT/GUID_INIT make sense to your? > > or _INITIALIZER? > > I'm a bit out of context. Where this will be used? include/uapi/linux/uuid.h (after the uuid lib changes) contains a definition of the macro GUID() which is probably a bit generic a name for a uapi include file. It also clashes with a couple of other uses of that macro name already in the kernel (one of which produced several warnings in linux-next today). It produces an initializer for a guid_t (structure). -- Cheers, Stephen Rothwell