mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
To: linux-kernel@vger.kernel.org
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	"Bryant G. Ly" <bryantly@linux.vnet.ibm.com>,
	"James E.J. Bottomley" <jejb@linux.vnet.ibm.com>,
	"Martin K. Petersen" <martin.petersen@oracle.com>,
	Alexandre Courbot <gnurou@gmail.com>,
	Artem Bityutskiy <dedekind1@gmail.com>,
	Bart Van Assche <Bart.VanAssche@sandisk.com>,
	Boris Brezillon <boris.brezillon@free-electrons.com>,
	Brian Norris <computersforpeace@gmail.com>,
	Cyrille Pitchen <cyrille.pitchen@wedev4u.fr>,
	David Woodhouse <dwmw2@infradead.org>,
	Hannes Reinecke <hare@suse.com>, Jan Kara <jack@suse.cz>,
	Jens Axboe <axboe@fb.com>,
	Linus Walleij <linus.walleij@linaro.org>,
	Marek Vasut <marek.vasut@gmail.com>,
	Michael Cyr <mikecyr@linux.vnet.ibm.com>,
	Mike Christie <mchristi@redhat.com>,
	Minchan Kim <minchan@kernel.org>, Nitin Gupta <ngupta@vflare.org>,
	Richard Weinberger <richard@nod.at>,
	Sergey Senozhatsky <sergey.senozhatsky.work@gmail.com>
Subject: [PATCH 0/7] Driver core: remove class_attrs from struct class
Date: Thu,  8 Jun 2017 10:12:35 +0200	[thread overview]
Message-ID: <20170608081242.27061-1-gregkh@linuxfoundation.org> (raw)

Some more patches that have long been sitting in a local tree...

The class_attrs field in struct class duplicates the same effort that
class_groups implements, so let's finally get rid of the last few users
of this field, and delete it, and the duplicated logic in the driver
core.

Subsystem maintainers, I'm glad to take this series in my driver core
tree, if you just want to ack your respective patches, that's fine with
me.

This series has passed 0-day test-builds from what I can tell.

Greg Kroah-Hartman (7):
  uwb: use class_groups instead of class_attrs
  scsi: ibmvscsi_tgt: remove use of class_attrs
  mtd: use class_groups instead of class_attrs
  zram: use class_groups instead of class_attrs
  gpio: use class_groups instead of class_attrs
  pktcdvd: use class_groups instead of class_attrs
  driver core: remove class_attrs from struct class

 drivers/base/class.c                     | 33 ------------------------------
 drivers/block/pktcdvd.c                  | 35 ++++++++++++++++----------------
 drivers/block/zram/zram_drv.c            | 26 ++++++++++++++----------
 drivers/gpio/gpiolib-sysfs.c             | 13 +++++++-----
 drivers/mtd/ubi/build.c                  | 16 ++++++++-------
 drivers/scsi/ibmvscsi_tgt/ibmvscsi_tgt.c |  5 -----
 drivers/uwb/driver.c                     | 11 +++++-----
 include/linux/device.h                   |  2 --
 8 files changed, 55 insertions(+), 86 deletions(-)

-- 
2.13.1

             reply	other threads:[~2017-06-08  8:12 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-06-08  8:12 Greg Kroah-Hartman [this message]
2017-06-08  8:12 ` [PATCH 1/7] uwb: use class_groups instead of class_attrs Greg Kroah-Hartman
2017-06-08  8:12 ` [PATCH 2/7] scsi: ibmvscsi_tgt: remove use " Greg Kroah-Hartman
2017-06-08 12:31   ` Bryant G. Ly
2017-06-08  8:12 ` [PATCH 3/7] mtd: use class_groups instead " Greg Kroah-Hartman
2017-06-08 10:23   ` Richard Weinberger
2017-06-08  8:12 ` [PATCH 4/7] zram: " Greg Kroah-Hartman
2017-06-09  5:39   ` Sergey Senozhatsky
2017-06-08  8:12 ` [PATCH 5/7] gpio: " Greg Kroah-Hartman
2017-06-08  8:23   ` Robert P. J. Day
2017-06-08 12:05   ` Linus Walleij
2017-06-08  8:12 ` [PATCH 6/7] pktcdvd: " Greg Kroah-Hartman
2017-06-08 14:05   ` Jens Axboe
2017-06-08  8:12 ` [PATCH 7/7] driver core: remove class_attrs from struct class Greg Kroah-Hartman

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20170608081242.27061-1-gregkh@linuxfoundation.org \
    --to=gregkh@linuxfoundation.org \
    --cc=Bart.VanAssche@sandisk.com \
    --cc=axboe@fb.com \
    --cc=boris.brezillon@free-electrons.com \
    --cc=bryantly@linux.vnet.ibm.com \
    --cc=computersforpeace@gmail.com \
    --cc=cyrille.pitchen@wedev4u.fr \
    --cc=dedekind1@gmail.com \
    --cc=dwmw2@infradead.org \
    --cc=gnurou@gmail.com \
    --cc=hare@suse.com \
    --cc=jack@suse.cz \
    --cc=jejb@linux.vnet.ibm.com \
    --cc=linus.walleij@linaro.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=marek.vasut@gmail.com \
    --cc=martin.petersen@oracle.com \
    --cc=mchristi@redhat.com \
    --cc=mikecyr@linux.vnet.ibm.com \
    --cc=minchan@kernel.org \
    --cc=ngupta@vflare.org \
    --cc=richard@nod.at \
    --cc=sergey.senozhatsky.work@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome