From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751742AbdFIKjG (ORCPT ); Fri, 9 Jun 2017 06:39:06 -0400 Received: from mout.kundenserver.de ([212.227.126.131]:64978 "EHLO mout.kundenserver.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751598AbdFIKjF (ORCPT ); Fri, 9 Jun 2017 06:39:05 -0400 From: Arnd Bergmann To: Ben Skeggs , David Airlie Cc: Arnd Bergmann , Daniel Vetter , dri-devel@lists.freedesktop.org, nouveau@lists.freedesktop.org, linux-kernel@vger.kernel.org Subject: [PATCH] drm/nouveau: use proper prototype in nouveau_pmops_runtime() definition Date: Fri, 9 Jun 2017 12:38:33 +0200 Message-Id: <20170609103851.3267574-1-arnd@arndb.de> X-Mailer: git-send-email 2.9.0 X-Provags-ID: V03:K0:dk+gcmjDFdeWWSGCyqWuuvYr67fCyLjAW9vx0IJOOxdrVU1tj9/ yTfNfnBo1NYmQJ4UI8h/UfpibN30IiBKKZJbLWtnJvUp84emmDwDPQcSgZ3y1aORiwoB1l7 BT1f2118Mk9yTXrYbc4UCMScTZEIqyqoTThSBgZWlAjsDOCX+Gair2Zwi0YIMTFyDNGyZTl y1Vs0Em93YThXIgk+Ee8Q== X-UI-Out-Filterresults: notjunk:1;V01:K0:cW3kpwTctiA=:xw9rzvHf25kY5roH6CiKwP ilrMGhcUO61T80nlU2zNoAoLM4xiDx97A0VpAlwKK15i62LJ3HilMPEXfxZUMGe08uZLo1b2f HDJP5kZ/PGHn52/fLho/IQOxOsK1vmmBaGBNW4Hid6UveCsSJO7rGC7hbHlhvoXR2Kdw5P9R+ qzg0jBC3O8InUCdfZlEsuYC6S57wDIu9/Wtk+FKjxFR8r/R0aBkE6bp2siBiVQDd0T2H9+zKg YcQFc3DpVpRwGuDdMnRGMYyZ035g7lzWn5u0ALhDwZ3FJWxPPQnrZrhRT3alqu2GkmaE1/4+/ lb6BPrKAZHQJDuCabWF4QtzqkUK4Odmd+7vPPihWTpz1wnMPCK5QpvcOLpbZB1QK4dzMs40MQ SESf9kJDLFZHL9w+T9tfAk6zqL5aMLKNd51IEaR08qjhHapG4+dvWETB51MjzJk1GZI4rTysn Rr7X6mqVeIsxyiiw8lMPSJarypOFSXdRoV5YXCXtlBTQ1iHOjECB+hqtfzxlr6ChgtnMFL2kO 5StpBASdwyrFIbi/dLSsnWcHsVRQ2r/yttnXMPaNCkm3+LqWRbHKiuXmg4A4s39Vlqp89BN7n v8UzNLv0HHZbQ9/Xs4/9TAag/u171AKOvfH8H426LY1BLmcPhcc8j9M8QfW3qnSaCvnXyaXJr 3wpC3SDE/HqRIlKzBaFptmAp/IVqbnN2d8HdHL85wFWO+KH8l3L7I7a377+pkxRKINjk= Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org There is a prototype for this function in the header, but the function itself lacks a 'void' in the argument list, causing a harmless warning when building with 'make W=1': drivers/gpu/drm/nouveau/nouveau_drm.c: In function 'nouveau_pmops_runtime': drivers/gpu/drm/nouveau/nouveau_drm.c:730:1: error: old-style function definition [-Werror=old-style-definition] Fixes: 321f5c5f2c49 ("drm/nouveau: replace multiple open-coded runpm support checks with function") Signed-off-by: Arnd Bergmann --- drivers/gpu/drm/nouveau/nouveau_drm.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/nouveau/nouveau_drm.c b/drivers/gpu/drm/nouveau/nouveau_drm.c index 7acd1cf8c5a6..90757af9bc73 100644 --- a/drivers/gpu/drm/nouveau/nouveau_drm.c +++ b/drivers/gpu/drm/nouveau/nouveau_drm.c @@ -727,7 +727,7 @@ nouveau_pmops_thaw(struct device *dev) } bool -nouveau_pmops_runtime() +nouveau_pmops_runtime(void) { if (nouveau_runtime_pm == -1) return nouveau_is_optimus() || nouveau_is_v1_dsm(); -- 2.9.0