mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Steven Rostedt <rostedt@goodmis.org>
To: linux-kernel@vger.kernel.org
Cc: Ingo Molnar <mingo@kernel.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	Jeremy Linton <jeremy.linton@arm.com>
Subject: [for-next][PATCH 07/12] trace: rename trace.c enum functions
Date: Thu, 15 Jun 2017 06:52:30 -0400	[thread overview]
Message-ID: <20170615105253.693823548@goodmis.org> (raw)
In-Reply-To: <20170615105223.551999981@goodmis.org>

[-- Attachment #1: 0007-trace-rename-trace.c-enum-functions.patch --]
[-- Type: text/plain, Size: 2209 bytes --]

From: Jeremy Linton <jeremy.linton@arm.com>

Rename the init and trace_enum_jmp_to_tail() routines
to reflect their use by more than enumerated types.

Link: http://lkml.kernel.org/r/20170531215653.3240-7-jeremy.linton@arm.com

Signed-off-by: Jeremy Linton <jeremy.linton@arm.com>
Signed-off-by: Steven Rostedt (VMware) <rostedt@goodmis.org>
---
 kernel/trace/trace.c | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/kernel/trace/trace.c b/kernel/trace/trace.c
index e0279f5dc83f..d703f429bbd9 100644
--- a/kernel/trace/trace.c
+++ b/kernel/trace/trace.c
@@ -4837,7 +4837,7 @@ static const struct file_operations tracing_enum_map_fops = {
 };
 
 static inline union trace_eval_map_item *
-trace_enum_jmp_to_tail(union trace_eval_map_item *ptr)
+trace_eval_jmp_to_tail(union trace_eval_map_item *ptr)
 {
 	/* Return tail of array given the head */
 	return ptr + ptr->head.length + 1;
@@ -4872,7 +4872,7 @@ trace_insert_enum_map_file(struct module *mod, struct trace_eval_map **start,
 	else {
 		ptr = trace_eval_maps;
 		for (;;) {
-			ptr = trace_enum_jmp_to_tail(ptr);
+			ptr = trace_eval_jmp_to_tail(ptr);
 			if (!ptr->tail.next)
 				break;
 			ptr = ptr->tail.next;
@@ -7735,7 +7735,7 @@ struct dentry *tracing_init_dentry(void)
 extern struct trace_eval_map *__start_ftrace_eval_maps[];
 extern struct trace_eval_map *__stop_ftrace_eval_maps[];
 
-static void __init trace_enum_init(void)
+static void __init trace_eval_init(void)
 {
 	int len;
 
@@ -7775,14 +7775,14 @@ static void trace_module_remove_enums(struct module *mod)
 	while (map) {
 		if (map->head.mod == mod)
 			break;
-		map = trace_enum_jmp_to_tail(map);
+		map = trace_eval_jmp_to_tail(map);
 		last = &map->tail.next;
 		map = map->tail.next;
 	}
 	if (!map)
 		goto out;
 
-	*last = trace_enum_jmp_to_tail(map)->tail.next;
+	*last = trace_eval_jmp_to_tail(map)->tail.next;
 	kfree(map);
  out:
 	mutex_unlock(&trace_eval_mutex);
@@ -7839,7 +7839,7 @@ static __init int tracer_init_tracefs(void)
 	trace_create_file("saved_cmdlines_size", 0644, d_tracer,
 			  NULL, &tracing_saved_cmdlines_size_fops);
 
-	trace_enum_init();
+	trace_eval_init();
 
 	trace_create_enum_file(d_tracer);
 
-- 
2.10.2

  parent reply	other threads:[~2017-06-15 10:54 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-06-15 10:52 [for-next][PATCH 00/12] tracing: Updates for 4.13 Steven Rostedt
2017-06-15 10:52 ` [for-next][PATCH 01/12] tracing: Remove unused declaration of trace_stop_cmdline_recording Steven Rostedt
2017-06-15 10:52 ` [for-next][PATCH 02/12] trace: rename kernel enum section to eval Steven Rostedt
2017-06-15 10:52 ` [for-next][PATCH 03/12] trace: rename trace_enum_map to trace_eval_map Steven Rostedt
2017-06-15 10:52 ` [for-next][PATCH 04/12] trace: rename struct module entry for trace enums Steven Rostedt
2017-06-15 10:52 ` [for-next][PATCH 05/12] trace: rename trace enum data structures in trace.c Steven Rostedt
2017-06-15 10:52 ` [for-next][PATCH 06/12] trace: rename trace_enum_mutex to trace_eval_mutex Steven Rostedt
2017-06-15 10:52 ` Steven Rostedt [this message]
2017-06-15 10:52 ` [for-next][PATCH 08/12] trace: rename enum_map functions Steven Rostedt
2017-06-15 10:52 ` [for-next][PATCH 09/12] tracing: Rename enum_replace to eval_replace Steven Rostedt
2017-06-15 10:52 ` [for-next][PATCH 10/12] tracing: define TRACE_DEFINE_SIZEOF() macro to map sizeofs to their values Steven Rostedt
2017-06-15 10:52 ` [for-next][PATCH 11/12] tracing: Add TRACE_DEFINE_SIZEOF() macros Steven Rostedt
2017-06-15 10:52 ` [for-next][PATCH 12/12] tracing: Rename update the enum_map file Steven Rostedt

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20170615105253.693823548@goodmis.org \
    --to=rostedt@goodmis.org \
    --cc=akpm@linux-foundation.org \
    --cc=jeremy.linton@arm.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®