From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752340AbdFUMJg (ORCPT ); Wed, 21 Jun 2017 08:09:36 -0400 Received: from mx2.suse.de ([195.135.220.15]:48690 "EHLO mx1.suse.de" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1751156AbdFUMJX (ORCPT ); Wed, 21 Jun 2017 08:09:23 -0400 Date: Wed, 21 Jun 2017 14:08:05 +0200 From: David Sterba To: Tejun Heo Cc: Nikolay Borisov , "David S. Miller" , Jens Axboe , Chris Mason , jbacik@fb.com, linux-mm@kvack.org, "Darrick J. Wong" , Jan Kara , mgorman@techsingularity.net, linux-kernel@vger.kernel.org Subject: Re: [PATCH] percpu_counter: Rename __percpu_counter_add to percpu_counter_add_batch Message-ID: <20170621120805.GG21388@suse.cz> Reply-To: dsterba@suse.cz Mail-Followup-To: dsterba@suse.cz, Tejun Heo , Nikolay Borisov , "David S. Miller" , Jens Axboe , Chris Mason , jbacik@fb.com, linux-mm@kvack.org, "Darrick J. Wong" , Jan Kara , mgorman@techsingularity.net, linux-kernel@vger.kernel.org References: <20170620172835.GA21326@htj.duckdns.org> <1497981680-6969-1-git-send-email-nborisov@suse.com> <20170620194759.GG21326@htj.duckdns.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20170620194759.GG21326@htj.duckdns.org> User-Agent: Mutt/1.5.23.1 (2014-03-12) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, Jun 20, 2017 at 03:47:59PM -0400, Tejun Heo wrote: > From 104b4e5139fe384431ac11c3b8a6cf4a529edf4a Mon Sep 17 00:00:00 2001 > From: Nikolay Borisov > Date: Tue, 20 Jun 2017 21:01:20 +0300 > > Currently, percpu_counter_add is a wrapper around __percpu_counter_add > which is preempt safe due to explicit calls to preempt_disable. Given > how __ prefix is used in percpu related interfaces, the naming > unfortunately creates the false sense that __percpu_counter_add is > less safe than percpu_counter_add. In terms of context-safety, > they're equivalent. The only difference is that the __ version takes > a batch parameter. > > Make this a bit more explicit by just renaming __percpu_counter_add to > percpu_counter_add_batch. > > This patch doesn't cause any functional changes. > > tj: Minor updates to patch description for clarity. Cosmetic > indentation updates. > > Signed-off-by: Nikolay Borisov > Signed-off-by: Tejun Heo > Cc: Chris Mason > Cc: Josef Bacik > Cc: David Sterba Acked-by: David Sterba