From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753770AbdGNJcx convert rfc822-to-8bit (ORCPT ); Fri, 14 Jul 2017 05:32:53 -0400 Received: from tyo161.gate.nec.co.jp ([114.179.232.161]:33908 "EHLO tyo161.gate.nec.co.jp" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753670AbdGNJcv (ORCPT ); Fri, 14 Jul 2017 05:32:51 -0400 From: Naoya Horiguchi To: Zi Yan CC: "kirill.shutemov@linux.intel.com" , "linux-kernel@vger.kernel.org" , "linux-mm@kvack.org" , "akpm@linux-foundation.org" , "minchan@kernel.org" , "vbabka@suse.cz" , "mgorman@techsingularity.net" , "mhocko@kernel.org" , "khandual@linux.vnet.ibm.com" , "zi.yan@cs.rutgers.edu" , "dnellans@nvidia.com" , "dave.hansen@intel.com" Subject: Re: [PATCH v8 06/10] mm: thp: check pmd migration entry in common path Thread-Topic: [PATCH v8 06/10] mm: thp: check pmd migration entry in common path Thread-Index: AQHS/IO5K/XonM3BE0iMs7p1dn+IIA== Date: Fri, 14 Jul 2017 09:29:43 +0000 Message-ID: <20170714092943.GA14125@hori1.linux.bs1.fc.nec.co.jp> References: <20170701134008.110579-1-zi.yan@sent.com> <20170701134008.110579-7-zi.yan@sent.com> In-Reply-To: <20170701134008.110579-7-zi.yan@sent.com> Accept-Language: en-US, ja-JP Content-Language: ja-JP X-MS-Has-Attach: X-MS-TNEF-Correlator: x-originating-ip: [10.128.101.4] Content-Type: text/plain; charset="iso-2022-jp" Content-ID: <5C963B16EB7721409607A6564AF92E06@gisp.nec.co.jp> Content-Transfer-Encoding: 8BIT MIME-Version: 1.0 X-TM-AS-MML: disable Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Sat, Jul 01, 2017 at 09:40:04AM -0400, Zi Yan wrote: > From: Zi Yan > > If one of callers of page migration starts to handle thp, > memory management code start to see pmd migration entry, so we need > to prepare for it before enabling. This patch changes various code > point which checks the status of given pmds in order to prevent race > between thp migration and the pmd-related works. > > ChangeLog v1 -> v2: > - introduce pmd_related() (I know the naming is not good, but can't > think up no better name. Any suggesntion is welcomed.) > > Signed-off-by: Naoya Horiguchi > > ChangeLog v2 -> v3: > - add is_swap_pmd() > - a pmd entry should be pmd pointing to pte pages, is_swap_pmd(), > pmd_trans_huge(), pmd_devmap(), or pmd_none() > - pmd_none_or_trans_huge_or_clear_bad() and pmd_trans_unstable() return > true on pmd_migration_entry, so that migration entries are not > treated as pmd page table entries. > > ChangeLog v4 -> v5: > - add explanation in pmd_none_or_trans_huge_or_clear_bad() to state > the equivalence of !pmd_present() and is_pmd_migration_entry() > - fix migration entry wait deadlock code (from v1) in follow_page_mask() > - remove unnecessary code (from v1) in follow_trans_huge_pmd() > - use is_swap_pmd() instead of !pmd_present() for pmd migration entry, > so it will not be confused with pmd_none() > - change author information > > ChangeLog v5 -> v7 > - use macro to disable the code when thp migration is not enabled > > ChangeLog v7 -> v8 > - remove not used code in do_huge_pmd_wp_page() > - copy the comment from change_pte_range() on downgrading > write migration entry to read to change_huge_pmd() > > Signed-off-by: Zi Yan > Cc: Kirill A. Shutemov > --- > arch/x86/mm/gup.c | 7 +++-- > fs/proc/task_mmu.c | 33 ++++++++++++++------- > include/asm-generic/pgtable.h | 17 ++++++++++- > include/linux/huge_mm.h | 14 +++++++-- > mm/gup.c | 22 ++++++++++++-- > mm/huge_memory.c | 67 +++++++++++++++++++++++++++++++++++++++---- > mm/memcontrol.c | 5 ++++ > mm/memory.c | 12 ++++++-- > mm/mprotect.c | 4 +-- > mm/mremap.c | 2 +- > 10 files changed, 154 insertions(+), 29 deletions(-) > > diff --git a/arch/x86/mm/gup.c b/arch/x86/mm/gup.c > index 456dfdfd2249..096bbcc801e6 100644 > --- a/arch/x86/mm/gup.c > +++ b/arch/x86/mm/gup.c > @@ -9,6 +9,7 @@ > #include > #include > #include > +#include > #include > > #include > @@ -243,9 +244,11 @@ static int gup_pmd_range(pud_t pud, unsigned long addr, unsigned long end, > pmd_t pmd = *pmdp; > > next = pmd_addr_end(addr, end); > - if (pmd_none(pmd)) > + if (!pmd_present(pmd)) { > + VM_BUG_ON(is_swap_pmd(pmd) && IS_ENABLED(CONFIG_MIGRATION) && > + !is_pmd_migration_entry(pmd)); This VM_BUG_ON() triggers when gup is called on hugetlb hwpoison entry. I think that in such case kernel falls into the gup slow path, and a page fault in follow_hugetlb_page() can properly report the error to affected processes, so no need to alarm with BUG_ON. Could you make this VM_BUG_ON more specific, or just remove it? Thanks, Naoya Horiguchi > return 0; > - if (unlikely(pmd_large(pmd) || !pmd_present(pmd))) { > + } else if (unlikely(pmd_large(pmd))) { > /* > * NUMA hinting faults need to be handled in the GUP > * slowpath for accounting purposes and so that they