From: Viresh Kumar <viresh.kumar@linaro.org>
To: Joel Fernandes <joelaf@google.com>
Cc: LKML <linux-kernel@vger.kernel.org>,
Juri Lelli <juri.lelli@arm.com>,
Patrick Bellasi <patrick.bellasi@arm.com>,
Andres Oportus <andresoportus@google.com>,
Dietmar Eggemann <dietmar.eggemann@arm.com>,
Srinivas Pandruvada <srinivas.pandruvada@linux.intel.com>,
Len Brown <lenb@kernel.org>,
"Rafael J . Wysocki" <rjw@rjwysocki.net>,
Ingo Molnar <mingo@redhat.com>,
Peter Zijlstra <peterz@infradead.org>
Subject: Re: [PATCH RFC v5] cpufreq: schedutil: Make iowait boost more energy efficient
Date: Tue, 18 Jul 2017 11:15:58 +0530 [thread overview]
Message-ID: <20170718054558.GU352@vireshk-i7> (raw)
In-Reply-To: <CAJWu+oqU+qVMM4M0k4d7YeUFV-Aq4vZUU3JyWrMy6GQHA1MLQw@mail.gmail.com>
On 17-07-17, 10:35, Joel Fernandes wrote:
> On Mon, Jul 17, 2017 at 1:04 AM, Viresh Kumar <viresh.kumar@linaro.org> wrote:
> > On 16-07-17, 01:04, Joel Fernandes wrote:
> >> + if (sg_cpu->iowait_boost_pending) {
> >> + sg_cpu->iowait_boost_pending = false;
> >> + sg_cpu->iowait_boost = min(sg_cpu->iowait_boost << 1,
> >> + sg_cpu->iowait_boost_max);
> >
> > Now this has a problem. We will also boost after waiting for
s/also/always/
> > rate_limit_us. And that's why I had proposed the tricky solution in
>
> Not really unless rate_limit_us is < TICK_NSEC? Once TICK_NSEC
> elapses, we would clear the boost in sugov_set_iowait_boost and in
> sugov_next_freq_shared.
You misread it and I know why it happened. And so I have sent a small
patch to make it a bit more readable.
rate_limit_us is associated with "last_freq_update_time", while
iowait-boost is associated with "last_update".
And last_update gets updated way too often.
> > the first place. I thought we wanted to avoid instant boost only for
> > the first iteration, but after that we wanted to do it ASAP. Isn't it?
> >
> > Now that you are using policy->min instead of policy->cur, we can
> > simplify the solution I proposed and always do 2 * iowait_boost before
>
> No, doubling on the first boost was never discussed or intended in my
> earlier patches. I thought even your patch never did, you were
> dividing by 2, and then scaling it back up by 2 before consuming it to
> preserve the initial boost.
>
> > getting current util/max in above if loop. i.e. we will start iowait
> > boost with min * 2 instead of min and that should be fine.
>
> Hmm, but why start from double of min? Why not just min? It doesn't
> make any difference to the intended behavior itself and is also
> consistent with my proposal in RFC v4. Also I feel what you're
> suggesting is more spike prone as well, the idea was to start from the
> minimum and double it as we go, not to double the min the first go.
> That was never intended.
>
> Also I would rather keep the "set and use and set and use" pattern to
> keep the logic less confusing and clean IMO.
> So we set initial boost in sugov_set_iowait_boost, and then in
> sugov_iowait_boost we use it, and then set the boost for the next time
> around at the end of sugov_iowait_boost (that is we double it). Next
> time sugov_set_iowait_boost wouldn't touch the boost whether iowait
> flag is set or not and we would continue into sugov_iowait_boost to
> consume the boost. This would have a small delay in reducing the
> boost, but that's Ok since its only one cycle of delay, and keeps the
> code clean. I assume the last part is not an issue considering you're
> proposing double of the initial boost anyway ;-)
Okay, let me try to explain the problem first and then you can propose
a solution if required.
Expected Behavior:
(Window refers to a time window of rate_limit_us here)
A. The first window where IOWAIT flag is set, we set boost to min-freq
and that shall be used for next freq update in
sugov_iowait_boost(). Any more calls to sugov_set_iowait_boost()
within this window shouldn't change the behavior.
B. If the next window also has IOWAIT flag set, then
sugov_iowait_boost() should use iowait*2 for freq update.
C. If a window doesn't have IOWAIT flag set, then sugov_iowait_boost()
should use iowait/2 in it.
Do they look fine to you?
Now coming to how will system behave with your patch:
A. would be fine. We will follow things properly.
But B. and C. aren't true anymore.
This happened because after the first window we updated iowait_boost
as 2*min unconditionally and the next window will *always* use that,
even if the flag isn't set. And we may end up increasing the frequency
unnecessarily, i.e. the spike where this discussion started.
And so in my initial solution I reversed the order in
sugov_iowait_boost().
--
viresh
next prev parent reply other threads:[~2017-07-18 5:46 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-07-16 8:04 Joel Fernandes
2017-07-17 8:04 ` Viresh Kumar
2017-07-17 17:35 ` Joel Fernandes
2017-07-18 5:45 ` Viresh Kumar [this message]
2017-07-18 14:02 ` Juri Lelli
2017-07-19 5:37 ` Viresh Kumar
2017-07-19 6:12 ` Joel Fernandes
2017-07-19 4:39 ` Joel Fernandes
2017-07-19 6:19 ` Viresh Kumar
2017-07-20 2:38 ` Joel Fernandes
2017-07-20 3:41 ` Viresh Kumar
2017-07-20 19:49 ` Joel Fernandes
2017-07-21 4:09 ` Viresh Kumar
2017-07-21 6:02 ` Joel Fernandes
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20170718054558.GU352@vireshk-i7 \
--to=viresh.kumar@linaro.org \
--cc=andresoportus@google.com \
--cc=dietmar.eggemann@arm.com \
--cc=joelaf@google.com \
--cc=juri.lelli@arm.com \
--cc=lenb@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=patrick.bellasi@arm.com \
--cc=peterz@infradead.org \
--cc=rjw@rjwysocki.net \
--cc=srinivas.pandruvada@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®