mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Kalle Valo <kvalo@codeaurora.org>
To: Brian Norris <briannorris@chromium.org>
Cc: Ganapathi Bhat <gbhat@marvell.com>,
	Nishant Sarmukadam <nishants@marvell.com>,
	<linux-kernel@vger.kernel.org>,
	Dmitry Torokhov <dmitry.torokhov@gmail.com>,
	Amitkumar Karwar <amitkarwar@gmail.com>,
	linux-wireless@vger.kernel.org,
	Brian Norris <briannorris@chromium.org>
Subject: Re: [v2,01/20] mwifiex: reunite copy-and-pasted remove/reset code
Date: Fri, 28 Jul 2017 14:49:15 +0000 (UTC)	[thread overview]
Message-ID: <20170728144915.83AC260272@smtp.codeaurora.org> (raw)
In-Reply-To: <20170725011336.99993-2-briannorris@chromium.org>

Brian Norris <briannorris@chromium.org> wrote:

> When PCIe FLR code was added, it explicitly copy-and-pasted much of
> mwifiex_remove_card() into mwifiex_shutdown_sw(). This is unnecessary,
> as almost all of the code should be reused.
> 
> Let's reunite what we can for now.
> 
> The only functional changes for now:
> 
>  * call netif_device_detach() in the remove() code path -- this wasn't
>    done before, but it really should be a no-op, when the device is
>    getting totally unregistered soon anyway
> 
>  * call the ->down_dev() driver callback only after we've finished all
>    SW teardown -- this should have no significant effect, since the only
>    user (pcie.c) does very minimal work there, and it doesn't matter
>    that we reorder this
> 
> Signed-off-by: Brian Norris <briannorris@chromium.org>

20 patches applied to wireless-drivers-next.git, thanks.

b6658b66d8a6 mwifiex: reunite copy-and-pasted remove/reset code
4b1f5a0d2eeb mwifiex: reset interrupt status across device reset
7dc4a6b5ca94 mwifiex: pcie: don't allow cmd buffer reuse after reset
643acea6297f mwifiex: re-register wiphy across reset
ce32d1d83702 mwifiex: unregister wiphy before freeing resources
6417dba33538 mwifiex: don't short-circuit netdev notifiers on interface deletion
c253a62da9b4 mwifiex: fixup init_channel_scan_gap error case
9557d9f2e62b mwifiex: ensure "disable auto DS" struct is initialized
5e6588b9d4ab mwifiex: fix misnomers in mwifiex_free_lock_list()
f7d7e4b689ca mwifiex: make mwifiex_free_cmd_buffer() return void
fe8d730adaee mwifiex: utilize netif_tx_{wake,stop}_all_queues()
8395fd9b194c mwifiex: don't open-code ARRAY_SIZE()
463df4719084 mwifiex: drop 'add_tail' param from mwifiex_insert_cmd_to_pending_q()
605db27f7405 mwifiex: pcie: remove unnecessary masks
87a602126aaf mwifiex: pcie: unify MSI-X / non-MSI-X interrupt process
37680819c6e1 mwifiex: debugfs: allow card_reset() to cancel things
2f47150ab3ef mwifiex: pcie: disable device DMA before unmapping/freeing buffers
43a0c9aea64d mwifiex: pcie: remove unnecessary 'pdev' check
2d98cfd17e92 mwifiex: keep mwifiex_cancel_pending_ioctl() static
0bc03cfd8247 mwifiex: drop num CPU notice

-- 
https://patchwork.kernel.org/patch/9860943/

https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches

  reply	other threads:[~2017-07-28 14:49 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-07-25  1:13 [PATCH v2 00/20] mwifiex: "reset" bugfixes and other refactorings Brian Norris
2017-07-25  1:13 ` [PATCH v2 01/20] mwifiex: reunite copy-and-pasted remove/reset code Brian Norris
2017-07-28 14:49   ` Kalle Valo [this message]
2017-07-25  1:13 ` [PATCH v2 02/20] mwifiex: reset interrupt status across device reset Brian Norris
2017-07-25  1:13 ` [PATCH v2 03/20] mwifiex: pcie: don't allow cmd buffer reuse after reset Brian Norris
2017-07-25  1:13 ` [PATCH v2 04/20] mwifiex: re-register wiphy across reset Brian Norris
2017-07-25  1:13 ` [PATCH v2 05/20] mwifiex: unregister wiphy before freeing resources Brian Norris
2017-07-25  1:13 ` [PATCH v2 06/20] mwifiex: don't short-circuit netdev notifiers on interface deletion Brian Norris
2017-07-25  1:13 ` [PATCH v2 07/20] mwifiex: fixup init_channel_scan_gap error case Brian Norris
2017-07-25  1:13 ` [PATCH v2 08/20] mwifiex: ensure "disable auto DS" struct is initialized Brian Norris
2017-07-25  1:13 ` [PATCH v2 09/20] mwifiex: fix misnomers in mwifiex_free_lock_list() Brian Norris
2017-07-25  1:13 ` [PATCH v2 10/20] mwifiex: make mwifiex_free_cmd_buffer() return void Brian Norris
2017-07-25  1:13 ` [PATCH v2 11/20] mwifiex: utilize netif_tx_{wake,stop}_all_queues() Brian Norris
2017-07-25  1:13 ` [PATCH v2 12/20] mwifiex: don't open-code ARRAY_SIZE() Brian Norris
2017-07-25  1:13 ` [PATCH v2 13/20] mwifiex: drop 'add_tail' param from mwifiex_insert_cmd_to_pending_q() Brian Norris
2017-07-25  1:13 ` [PATCH v2 14/20] mwifiex: pcie: remove unnecessary masks Brian Norris
2017-07-25  1:13 ` [PATCH v2 15/20] mwifiex: pcie: unify MSI-X / non-MSI-X interrupt process Brian Norris
2017-07-25  1:13 ` [PATCH v2 16/20] mwifiex: debugfs: allow card_reset() to cancel things Brian Norris
2017-07-25  1:13 ` [PATCH v2 17/20] mwifiex: pcie: disable device DMA before unmapping/freeing buffers Brian Norris
2017-07-25  1:13 ` [PATCH v2 18/20] mwifiex: pcie: remove unnecessary 'pdev' check Brian Norris
2017-07-25  1:13 ` [PATCH v2 19/20] mwifiex: keep mwifiex_cancel_pending_ioctl() static Brian Norris
2017-07-25  1:13 ` [PATCH v2 20/20] mwifiex: drop num CPU notice Brian Norris

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20170728144915.83AC260272@smtp.codeaurora.org \
    --to=kvalo@codeaurora.org \
    --cc=amitkarwar@gmail.com \
    --cc=briannorris@chromium.org \
    --cc=dmitry.torokhov@gmail.com \
    --cc=gbhat@marvell.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-wireless@vger.kernel.org \
    --cc=nishants@marvell.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome