From: Matt Roper <matthew.d.roper@intel.com>
To: Jean Delvare <jdelvare@suse.de>
Cc: intel-gfx@lists.freedesktop.org,
Mauro Carvalho Chehab <mchehab@osg.samsung.com>,
linux-edac@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 6/8] dmi: Move memdev_dmi_entry definition to dmi.h (v2)
Date: Wed, 9 Aug 2017 09:18:49 -0700 [thread overview]
Message-ID: <20170809161849.GA4496@mdroper-desk.amr.corp.intel.com> (raw)
In-Reply-To: <20170731103605.1810e281@endymion>
On Mon, Jul 31, 2017 at 10:36:05AM +0200, Jean Delvare wrote:
> Hi Matt, Mauro,
>
> On Thu, 17 Mar 2016 15:18:20 +0100, Jean Delvare wrote:
> > On Tue, 8 Mar 2016 10:32:37 -0800, Matt Roper wrote:
> > > A couple of the EDAC drivers have a nice memdev_dmi_entry structure for
> > > decoding DMI memory device entries. Move the structure definition to
> > > dmi.h so that it can be shared between those drivers and also other
> > > parts of the kernel; the i915 graphics driver is going to need to use
> > > this structure soon as well. As part of this move we rename the
> > > structure s/memdev_dmi_entry/dmi_entry_memdev/ to ensure it has a proper
> > > 'dmi' prefix.
> > >
> > > v2:
> > > - Rename structure to dmi_entry_memdev. (Jean)
> > > - Use __packed instead of __attribute__((__packed__)) for consistency
> > > with the rest of the dmi.h header. (Jean)
> >
> > Looks better. (...)
>
> What happened to this patch? I never received v3. Is it sill needed?
We ended up going a different direction in the graphics driver and wound
up not needing access to this structure. If there's still interest in
the general refactoring here, let me know and I can incorporate your
last feedback and respin a v3.
Matt
> --
> Jean Delvare
> SUSE L3 Support
--
Matt Roper
Graphics Software Engineer
IoTG Platform Enabling & Development
Intel Corporation
(916) 356-2795
next prev parent reply other threads:[~2017-08-09 16:18 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <1457399146-4578-1-git-send-email-matthew.d.roper@intel.com>
2016-03-08 1:05 ` [PATCH 6/8] dmi: Move memdev_dmi_entry definition to dmi.h Matt Roper
2016-03-08 12:37 ` Jean Delvare
2016-03-08 18:32 ` [PATCH 6/8] dmi: Move memdev_dmi_entry definition to dmi.h (v2) Matt Roper
2016-03-17 14:18 ` Jean Delvare
2017-07-31 8:36 ` Jean Delvare
2017-08-09 16:18 ` Matt Roper [this message]
2017-08-10 9:39 ` Jean Delvare
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20170809161849.GA4496@mdroper-desk.amr.corp.intel.com \
--to=matthew.d.roper@intel.com \
--cc=intel-gfx@lists.freedesktop.org \
--cc=jdelvare@suse.de \
--cc=linux-edac@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mchehab@osg.samsung.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®