From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752407AbdHQIRS (ORCPT ); Thu, 17 Aug 2017 04:17:18 -0400 Received: from mail-wr0-f193.google.com ([209.85.128.193]:33906 "EHLO mail-wr0-f193.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751798AbdHQIRO (ORCPT ); Thu, 17 Aug 2017 04:17:14 -0400 Date: Thu, 17 Aug 2017 10:17:10 +0200 From: Ingo Molnar To: Byungchul Park Cc: peterz@infradead.org, linux-kernel@vger.kernel.org, kernel-team@lge.com Subject: Re: [PATCH v2] lockdep: Make LOCKDEP_CROSSRELEASE configs all part of PROVE_LOCKING Message-ID: <20170817081710.kvcjznjcsw7peaml@gmail.com> References: <1502957199-12156-1-git-send-email-byungchul.park@lge.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1502957199-12156-1-git-send-email-byungchul.park@lge.com> User-Agent: NeoMutt/20170113 (1.7.2) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org * Byungchul Park wrote: > Crossrelease added LOCKDEP_CROSSRELEASE and LOCKDEP_COMPLETE configs. It > makes little sense to enable them when PROVE_LOCKING is disabled. > > Make them non-interative option and all part of PROVE_LOCKING. > > Signed-off-by: Byungchul Park > --- > lib/Kconfig.debug | 7 ++----- > 1 file changed, 2 insertions(+), 5 deletions(-) > > diff --git a/lib/Kconfig.debug b/lib/Kconfig.debug > index ee9e534..84bb4c5 100644 > --- a/lib/Kconfig.debug > +++ b/lib/Kconfig.debug > @@ -1084,6 +1084,8 @@ config PROVE_LOCKING > select DEBUG_MUTEXES > select DEBUG_RT_MUTEXES if RT_MUTEXES > select DEBUG_LOCK_ALLOC > + select LOCKDEP_CROSSRELEASE > + select LOCKDEP_COMPLETE > select TRACE_IRQFLAGS > default n > help > @@ -1155,8 +1157,6 @@ config LOCK_STAT > > config LOCKDEP_CROSSRELEASE > bool "Lock debugging: make lockdep work for crosslocks" > - depends on PROVE_LOCKING > - default n > help > This makes lockdep work for crosslock which is a lock allowed to > be released in a different context from the acquisition context. > @@ -1167,9 +1167,6 @@ config LOCKDEP_CROSSRELEASE > > config LOCKDEP_COMPLETE > bool "Lock debugging: allow completions to use deadlock detector" > - depends on PROVE_LOCKING > - select LOCKDEP_CROSSRELEASE > - default n BTW., and I just noticed this, "LOCKDEP_COMPLETE" is a misnomer: it should be "LOCKDEP_COMPLETIONS". Think about it, 'complete' is an adjective, and the current name suggests 'lockdep is complete' or so, so it's pretty confusing. So let's do a (separate) renaming patch as well. Also, while at it: > bool "Lock debugging: make lockdep work for crosslocks" Please word that more directly - lockdep doesn't have to be made to work with crosslocks - it works with them, what the option does is that it enables crosslock support. I.e.: bool "Lock debugging: enable cross-locking checks in lockdep" or so. Thanks, Ingo