From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751321AbdH3FT2 (ORCPT ); Wed, 30 Aug 2017 01:19:28 -0400 Received: from mga02.intel.com ([134.134.136.20]:52485 "EHLO mga02.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750814AbdH3FT1 (ORCPT ); Wed, 30 Aug 2017 01:19:27 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.41,447,1498546800"; d="scan'208";a="145484575" From: "Huang, Ying" To: Andrew Morton Cc: linux-mm@kvack.org, linux-kernel@vger.kernel.org, Huang Ying Subject: [PATCH -mm] mm: Improve readability of clear_huge_page Date: Wed, 30 Aug 2017 13:18:42 +0800 Message-Id: <20170830051842.1397-1-ying.huang@intel.com> X-Mailer: git-send-email 2.13.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org From: Huang Ying The optimized clear_huge_page() isn't easy to read and understand. This is suggested by Michael Hocko to improve it. Suggested-by: Michal Hocko Signed-off-by: "Huang, Ying" --- mm/memory.c | 11 +++++++---- 1 file changed, 7 insertions(+), 4 deletions(-) diff --git a/mm/memory.c b/mm/memory.c index 20ac58c128e9..694ddbd3a020 100644 --- a/mm/memory.c +++ b/mm/memory.c @@ -4507,12 +4507,15 @@ void clear_huge_page(struct page *page, * towards the sub-page to access */ for (i = 0; i < l; i++) { + int left_idx = base + i; + int right_idx = base + 2 * l - 1 - i; + cond_resched(); - clear_user_highpage(page + base + i, - addr + (base + i) * PAGE_SIZE); + clear_user_highpage(page + left_idx, + addr + left_idx * PAGE_SIZE); cond_resched(); - clear_user_highpage(page + base + 2 * l - 1 - i, - addr + (base + 2 * l - 1 - i) * PAGE_SIZE); + clear_user_highpage(page + right_idx, + addr + right_idx * PAGE_SIZE); } } -- 2.13.2