From: himanshi <himshijain.hj@gmail.com>
To: Dan Carpenter <dan.carpenter@oracle.com>
Cc: outreachy-kernel@googlegroups.com, lars@metafoo.de,
Michael.Hennerich@analog.com, jic23@kernel.org, knaack.h@gmx.de,
pmeerw@pmeerw.net, gregkh@linuxfoundation.org,
linux-iio@vger.kernel.org, devel@driverdev.osuosl.org,
linux-kernel@vger.kernel.org, nick.desaulniers@gmail.com,
daniel.baluta@gmail.com
Subject: Re: [PATCH 2/2] iio: Use __ATTR_NAMED to allow passing name as string to IIO_DEVICE_ATTR_NAMED and change usage to pass string
Date: Wed, 13 Sep 2017 14:17:59 +0530 [thread overview]
Message-ID: <20170913084759.GA5388@himanshi-Inspiron-5558> (raw)
In-Reply-To: <20170913081221.udzpojijvm44ht45@mwanda>
On Wed, Sep 13, 2017 at 11:12:21AM +0300, Dan Carpenter wrote:
> On Wed, Sep 13, 2017 at 01:26:27PM +0530, Himanshi Jain wrote:
> > Add IIO_ATTR_NAMED macro to use __ATTR_NAMED to allow passing name as
> > string to IIO_DEVICE_ATTR_NAMED. Change current usage of
> > IIO_DEVICE_ATTR_NAMED to pass name as string.
> >
> > Signed-off-by: Himanshi Jain <himshijain.hj@gmail.com>
>
> This version looks nice. The subject is just *way* too long, though.
> Also you have put a v2 in the subject and a little changelog after the
> --- cut off. Just call it something like:
> [PATCH 2/2 v2] iio: Change to __ATTR_NAMED()
>
> regards,
> dan carpenter
Thank you for the review Dan! Does it look fine now in v2?
prev parent reply other threads:[~2017-09-13 8:48 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-09-13 7:54 [PATCH 0/2] Rewrite the IIO_DEVICE_ATTR_NAMED API to pass name as string Himanshi Jain
2017-09-13 7:56 ` [PATCH 1/2] include: linux: sysfs: Add __ATTR_NAMED macro Himanshi Jain
2017-09-13 7:56 ` [PATCH 2/2] iio: Use __ATTR_NAMED to allow passing name as string to IIO_DEVICE_ATTR_NAMED and change usage to pass string Himanshi Jain
2017-09-13 8:12 ` Dan Carpenter
2017-09-13 8:47 ` himanshi [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20170913084759.GA5388@himanshi-Inspiron-5558 \
--to=himshijain.hj@gmail.com \
--cc=Michael.Hennerich@analog.com \
--cc=dan.carpenter@oracle.com \
--cc=daniel.baluta@gmail.com \
--cc=devel@driverdev.osuosl.org \
--cc=gregkh@linuxfoundation.org \
--cc=jic23@kernel.org \
--cc=knaack.h@gmx.de \
--cc=lars@metafoo.de \
--cc=linux-iio@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=nick.desaulniers@gmail.com \
--cc=outreachy-kernel@googlegroups.com \
--cc=pmeerw@pmeerw.net \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®