From: John Keeping <john@keeping.me.uk>
To: Sean Paul <seanpaul@chromium.org>
Cc: Brian Norris <briannorris@chromium.org>,
mark.rutland@arm.com, bivvy.bi@rock-chips.com, hl@rock-chips.com,
heiko@sntech.de, airlied@linux.ie, linux-kernel@vger.kernel.org,
dri-devel@lists.freedesktop.org,
linux-rockchip@lists.infradead.org,
Nickey Yang <nickey.yang@rock-chips.com>,
robh+dt@kernel.org, zyw@rock-chips.com, xbl@rock-chips.com,
mark.yao@rock-chips.com
Subject: Re: [PATCH 1/7] drm/rockchip/dsi: correct Feedback divider setting
Date: Wed, 20 Sep 2017 11:08:51 +0100 [thread overview]
Message-ID: <20170920100851.GI1601@john.keeping.me.uk> (raw)
In-Reply-To: <20170919202740.2ku56pefrj3wyskw@art_vandelay>
On Tue, Sep 19, 2017 at 01:27:40PM -0700, Sean Paul wrote:
> On Tue, Sep 19, 2017 at 11:19:01AM -0700, Brian Norris wrote:
> > Hi Sean,
> >
> > On Tue, Sep 19, 2017 at 11:00:25AM -0700, Sean Paul wrote:
> > > On Mon, Sep 18, 2017 at 05:05:33PM +0800, Nickey Yang wrote:
> > > > This patch correct Feedback divider setting:
> > > > 1、Set Feedback divider [8:5] when HIGH_PROGRAM_EN
> > > > 2、Due to the use of a "by 2 pre-scaler," the range of the
> > > > feedback multiplication Feedback divider is limited to even
> > > > division numbers, and Feedback divider must be greater than
> > > > 12, less than 1000.
> > > > 3、Make the previously configured Feedback divider(LSB)
> > > > factors effective
> > > >
> > > > Signed-off-by: Nickey Yang <nickey.yang@rock-chips.com>
> > > > ---
> > > > drivers/gpu/drm/rockchip/dw-mipi-dsi.c | 83 ++++++++++++++++++++++------------
> > > > 1 file changed, 54 insertions(+), 29 deletions(-)
> > > >
> > > > diff --git a/drivers/gpu/drm/rockchip/dw-mipi-dsi.c b/drivers/gpu/drm/rockchip/dw-mipi-dsi.c
> > > > index 9a20b9d..52698b7 100644
> > > > --- a/drivers/gpu/drm/rockchip/dw-mipi-dsi.c
> > > > +++ b/drivers/gpu/drm/rockchip/dw-mipi-dsi.c
> > > > @@ -228,7 +228,7 @@
> > > > #define LOW_PROGRAM_EN 0
> > > > #define HIGH_PROGRAM_EN BIT(7)
> > > > #define LOOP_DIV_LOW_SEL(val) (((val) - 1) & 0x1f)
> > > > -#define LOOP_DIV_HIGH_SEL(val) ((((val) - 1) >> 5) & 0x1f)
> > > > +#define LOOP_DIV_HIGH_SEL(val) ((((val) - 1) >> 5) & 0xf)
> > > > #define PLL_LOOP_DIV_EN BIT(5)
> > > > #define PLL_INPUT_DIV_EN BIT(4)
> > > >
> > > > @@ -461,6 +461,7 @@ static int dw_mipi_dsi_phy_init(struct dw_mipi_dsi *dsi)
> > > > dw_mipi_dsi_phy_write(dsi, 0x17, INPUT_DIVIDER(dsi->input_div));
> > > > dw_mipi_dsi_phy_write(dsi, 0x18, LOOP_DIV_LOW_SEL(dsi->feedback_div) |
> > > > LOW_PROGRAM_EN);
> > > > + dw_mipi_dsi_phy_write(dsi, 0x19, PLL_LOOP_DIV_EN | PLL_INPUT_DIV_EN);
> > >
> > > You do the same write 2 lines down. Are both needed? It would be nice if the
> > > register names were also defined, so this is easier to read.
> >
> > If I'm reading correctly, I think this is what Nickey meant by:
> >
> > "3、Make the previously configured Feedback divider(LSB)
> > factors effective"
> >
> > . My reading of the databook is that this step finalizes the previous
> > two writes (to test code 0x17 and 0x18).
> >
> > Given this was buggy (?) previously, it does seem like having some extra
> > language to document this could help. Register names (or "test codes",
> > per the docs?) could help, but additionally, maybe a few more comments.
> >
>
> Ah, yeah, thanks for the explanation. It's not clear that this latches the
> values above. I think register names and comments would be immensely helpful.
According to the databook, 0x19 controls whether the loop/input dividers
are derived from the hsfreqrange configuration or use the values in 0x17
and 0x18. I can't see why writing the same value to this register
multiple times is necessary.
> > > > dw_mipi_dsi_phy_write(dsi, 0x18, LOOP_DIV_HIGH_SEL(dsi->feedback_div) |
> > > > HIGH_PROGRAM_EN);
> > > > dw_mipi_dsi_phy_write(dsi, 0x19, PLL_LOOP_DIV_EN | PLL_INPUT_DIV_EN);
> >
> > [...]
next prev parent reply other threads:[~2017-09-20 10:17 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-09-18 9:05 Nickey Yang
2017-09-18 9:05 ` [PATCH 2/7] drm/rockchip/dsi: add dual mipi channel support Nickey Yang
2017-09-19 20:25 ` Sean Paul
2017-09-18 9:05 ` [PATCH 3/7] dt-bindings: add the rockchip,dual-channel for dw-mipi-dsi Nickey Yang
2017-09-18 21:56 ` Brian Norris
2017-09-18 9:05 ` [PATCH 4/7] drm/rockchip/dsi: correct phy parameter setting Nickey Yang
2017-09-19 20:32 ` Sean Paul
2017-09-18 9:05 ` [PATCH 5/7] arm64: dts: rockchip: rk3399: Correct MIPI DPHY PLL clock Nickey Yang
2017-09-18 11:31 ` Heiko Stübner
2017-09-20 10:28 ` Heiko Stübner
2017-09-18 23:29 ` [PATCH 1/7] drm/rockchip/dsi: correct Feedback divider setting Brian Norris
2017-09-19 18:00 ` Sean Paul
2017-09-19 18:19 ` Brian Norris
2017-09-19 20:27 ` Sean Paul
2017-09-20 10:08 ` John Keeping [this message]
2017-09-20 11:08 ` hl
2017-09-20 12:07 ` John Keeping
2017-09-22 22:57 ` Matthias Kaehlcke
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20170920100851.GI1601@john.keeping.me.uk \
--to=john@keeping.me.uk \
--cc=airlied@linux.ie \
--cc=bivvy.bi@rock-chips.com \
--cc=briannorris@chromium.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=heiko@sntech.de \
--cc=hl@rock-chips.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-rockchip@lists.infradead.org \
--cc=mark.rutland@arm.com \
--cc=mark.yao@rock-chips.com \
--cc=nickey.yang@rock-chips.com \
--cc=robh+dt@kernel.org \
--cc=seanpaul@chromium.org \
--cc=xbl@rock-chips.com \
--cc=zyw@rock-chips.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome