From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752484AbdI1IVo (ORCPT ); Thu, 28 Sep 2017 04:21:44 -0400 Received: from mail-wr0-f170.google.com ([209.85.128.170]:53693 "EHLO mail-wr0-f170.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752017AbdI1IVl (ORCPT ); Thu, 28 Sep 2017 04:21:41 -0400 X-Google-Smtp-Source: AOwi7QBPJovc8GpOzro/PqFJH5jUWRL23qga6mIyacQb3UnpLP1yohuICYvkPz8VzSLsOU/wbs1ntw== Date: Thu, 28 Sep 2017 10:21:38 +0200 From: Ingo Molnar To: "Kirill A. Shutemov" Cc: Ingo Molnar , Linus Torvalds , x86@kernel.org, Thomas Gleixner , "H. Peter Anvin" , Andrew Morton , Andy Lutomirski , Cyrill Gorcunov , Borislav Petkov , linux-mm@kvack.org, linux-kernel@vger.kernel.org Subject: Re: [PATCHv7 08/19] x86/mm: Make PGDIR_SHIFT and PTRS_PER_P4D variable Message-ID: <20170928082138.ayuwbf6jhy6yyqu4@gmail.com> References: <20170918105553.27914-1-kirill.shutemov@linux.intel.com> <20170918105553.27914-9-kirill.shutemov@linux.intel.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20170918105553.27914-9-kirill.shutemov@linux.intel.com> User-Agent: NeoMutt/20170113 (1.7.2) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org * Kirill A. Shutemov wrote: > #define P4D_SHIFT 39 > -#define PTRS_PER_P4D 512 > +#define __PTRS_PER_P4D 512 > +#define PTRS_PER_P4D ptrs_per_p4d > #define P4D_SIZE (_AC(1, UL) << P4D_SHIFT) > #define P4D_MASK (~(P4D_SIZE - 1)) PTRS_PER_P4D_MAX would be a better name than random underscores ... Thanks, Ingo