From: Dan Carpenter <dan.carpenter@oracle.com>
To: Ioana Radulescu <ruxandra.radulescu@nxp.com>
Cc: devel@driverdev.osuosl.org, arnd@arndb.de, stuyoder@gmail.com,
gregkh@linuxfoundation.org, roy.pledge@nxp.com,
linux-kernel@vger.kernel.org, agraf@suse.de,
bogdan.purcareata@nxp.com, laurentiu.tudor@nxp.com
Subject: Re: [PATCH] staging: fsl-mc/dpio: Fix incorrect comparison
Date: Thu, 28 Sep 2017 15:53:37 +0300 [thread overview]
Message-ID: <20170928125337.fl3pyuqi7jevz2no@mwanda> (raw)
In-Reply-To: <20170928124836.kdqjowqibab53hf5@mwanda>
On Thu, Sep 28, 2017 at 03:48:36PM +0300, Dan Carpenter wrote:
> On Wed, Sep 27, 2017 at 12:57:28PM -0500, Ioana Radulescu wrote:
> > diff --git a/drivers/staging/fsl-mc/bus/dpio/dpio-service.c b/drivers/staging/fsl-mc/bus/dpio/dpio-service.c
> > index f809682..26922fc 100644
> > --- a/drivers/staging/fsl-mc/bus/dpio/dpio-service.c
> > +++ b/drivers/staging/fsl-mc/bus/dpio/dpio-service.c
> > @@ -76,7 +76,7 @@ static inline struct dpaa2_io *service_select_by_cpu(struct dpaa2_io *d,
> > if (d)
> > return d;
> >
> > - if (unlikely(cpu >= num_possible_cpus()))
> > + if (unlikely(cpu >= (int)num_possible_cpus()))
>
>
> Drivers shouldn't use likely/unlikley. Please write it more explicitly
> like this:
>
> if (cpu != -1 && cpu >= num_possible_cpus())
This would probably be more readable as a define.
if (cpu != DPAA_ANY_CPU && cpu >= num_possible_cpus())
return NULL;
regards,
dan carpenter
next prev parent reply other threads:[~2017-09-28 12:54 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-09-27 17:57 Ioana Radulescu
2017-09-28 12:48 ` Dan Carpenter
2017-09-28 12:53 ` Dan Carpenter [this message]
2017-09-28 13:07 ` Ruxandra Ioana Radulescu
2017-09-28 13:17 ` gregkh
2017-09-28 13:23 ` Ruxandra Ioana Radulescu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20170928125337.fl3pyuqi7jevz2no@mwanda \
--to=dan.carpenter@oracle.com \
--cc=agraf@suse.de \
--cc=arnd@arndb.de \
--cc=bogdan.purcareata@nxp.com \
--cc=devel@driverdev.osuosl.org \
--cc=gregkh@linuxfoundation.org \
--cc=laurentiu.tudor@nxp.com \
--cc=linux-kernel@vger.kernel.org \
--cc=roy.pledge@nxp.com \
--cc=ruxandra.radulescu@nxp.com \
--cc=stuyoder@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®