From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751522AbdJERai (ORCPT ); Thu, 5 Oct 2017 13:30:38 -0400 Received: from smtp.codeaurora.org ([198.145.29.96]:49706 "EHLO smtp.codeaurora.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751330AbdJERag (ORCPT ); Thu, 5 Oct 2017 13:30:36 -0400 DMARC-Filter: OpenDMARC Filter v1.3.2 smtp.codeaurora.org 1FB1C600EC Authentication-Results: pdx-caf-mail.web.codeaurora.org; dmarc=none (p=none dis=none) header.from=codeaurora.org Authentication-Results: pdx-caf-mail.web.codeaurora.org; spf=none smtp.mailfrom=sboyd@codeaurora.org Date: Thu, 5 Oct 2017 10:30:34 -0700 From: Stephen Boyd To: Viresh Kumar Cc: Rafael Wysocki , Viresh Kumar , Nishanth Menon , linux-pm@vger.kernel.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH] PM / OPP: Rename dev_pm_opp_register_put_opp_helper() Message-ID: <20171005173034.GE457@codeaurora.org> References: <0d69b3a1e8b565815c1f5a77f5622b524f6f7d35.1507204552.git.viresh.kumar@linaro.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <0d69b3a1e8b565815c1f5a77f5622b524f6f7d35.1507204552.git.viresh.kumar@linaro.org> User-Agent: Mutt/1.5.21 (2010-09-15) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 10/05, Viresh Kumar wrote: > The routine is named incorrectly since the first attempt as there is > nothing like a put_opp() helper. We wanted to unregister the set_opp() > helper here and so it should rather be named as > dev_pm_opp_unregister_set_opp_helper(). > > Signed-off-by: Viresh Kumar > --- Reviewed-by: Stephen Boyd -- Qualcomm Innovation Center, Inc. is a member of Code Aurora Forum, a Linux Foundation Collaborative Project