From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751607AbdJHJQ7 (ORCPT ); Sun, 8 Oct 2017 05:16:59 -0400 Received: from bombadil.infradead.org ([65.50.211.133]:44122 "EHLO bombadil.infradead.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751457AbdJHJQ6 (ORCPT ); Sun, 8 Oct 2017 05:16:58 -0400 Date: Sun, 8 Oct 2017 02:16:54 -0700 From: Christoph Hellwig To: Konstantin Khlebnikov Cc: linux-mm@kvack.org, Andrew Morton , linux-kernel@vger.kernel.org, Andy Lutomirski Subject: Re: [PATCH] vmalloc: add __alloc_vm_area() for optimizing vmap stack Message-ID: <20171008091654.GA29939@infradead.org> References: <150728974697.743944.5376694940133890044.stgit@buzz> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <150728974697.743944.5376694940133890044.stgit@buzz> User-Agent: Mutt/1.8.3 (2017-05-23) X-SRS-Rewrite: SMTP reverse-path rewritten from by bombadil.infradead.org. See http://www.infradead.org/rpr.html Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org This looks fine in general, but a few comments: - can you split adding the new function from switching over the fork code? - at least kasan and vmalloc_user/vmalloc_32_user use very similar patterns, can you switch them over as well? - the new __alloc_vm_area looks very different from alloc_vm_area, maybe it needs a better name? vmalloc_range_area for example? - when you split an existing function please keep the more low-level function on top of the higher level one that calls it.